VNC Connect on Startup Issues

What is the problem?

Octodash doesn't always load on startup. VNC Connect screen pops up instead. Restart usually helps, but lose direct file transfer from Prusaslicer.

What did you already try to solve it?

Updated everything. Restarting Pi helps sometimes. Disabled VNC through sudo raspi-config, but it disables the ability to directly transfer G-code from Prusaslicer

Have you tried running in safe mode?

No, not sure how.

Did running in safe mode solve the problem?

Did not try

Complete Logs

No sure how to do this. I am an amateur.

Additional information about your setup

OctoPrint 1.5.3, Prusa i3 MK3S+ printer

A minor hint: The blue words like safe mode and logs are links: You may click them.

Do I even need VNC Connect enabled in raspi-config?

What functionality will I lose if I disable it?

I’ll try to get the logs tonight. It’s been a frustrating journey.