Watched dir isn't watched

What is the problem?

bringing up brand new printer, a Two Trees Saphire5plus
used linux instructs to install octoprint on a bananapi m5, no problems.
Activated venv Saphire5plus
used pip to install 1.8.6
Started "octoprint serve" in this Saphire5plus named venv
web page configure says folder paths are valid
not using ~.OctoPrint as an input dir because I'm an mc user, have a many machine home sshfs net setup.
but mc does not see dotted directorys so I can't use .OctoPrint

So I've made ~/oprnt/Saphire5plus/uploads and watched directories, works on a rock64 MOST of the time.
but a new cura output placed in that watched directory is ignored, perms are 0755. Web page at bpi51:5000
says paths are valid.

But a .gcode file placed in watched is ignored by octoprint's "files" menu.

How to fix?

rechecked folders menu in config many times, all good

What did you already try to solve it?


Have you tried running in safe mode?

Don't know how.

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (7.3 KB)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


version 1.8.6, running on a bpi5, drag - n - drop from thunar works as a method to get a file into the priint queue, but placing files in "watched" directory does not.

Hopefully this will be fixed in next upgrade?
I just found the sysinfo thing and downloaded it getting a complaint that seriel logging wasn;t enabled. Seriel comm with the printer is fine and has nothing to do with my problem. The printer is not working ATM. controller board config problems in marlin, new board is not exact for OEM, two trees is slow help at best, have voron trident on order.

Are you using the default watched folder or have you configured it in the settings to point somewhere else? Does it work correctly at the default location (usually on Linux ~/.octoprint/watched).

If I understand your initial post correctly, it sounds like you might have configured it to be on a network share? Or is that not the case?

If you are using this as a way to get your files from Cura to OctoPrint, I can highly recommend using the Cura OctoPrint Connection Plugin.

I generally use mc to move cura's output over an sshfs network share, but sshfs will not work for a dot hidden path like ~/.octoprint, so I've made an oprnt directory in my user tree on the client bpi5's running armbian, with a printer-named subdir containing the uploads and watched directories. Older octoprints worked just fine, but 1.8.6 doesn't so while I can write to:
/sshnet/bpi51/me/oprnt/Sappire5/watched, and it eventually disappears, it does not disappear into the octoprint print queue, I have to goto that machine and run a copy of thunar to drag-n-drop it in the printer in-queue.

ATM that printer is on the disabled list, it came with a Makebase Robin Nano 1.2 control board, which I as a LinuxCNC use love due to it having separately headed "gnd,en,step,and dir" pins I can grab and use to drive much more powerful nema-unameit motor controllers, and one of the changes I've made to an Ender5+ is replacing the puny, always losing home nema-17 Y motor with a 25mm cf tube to join the end pulleys, and putting a 3 phase stepper/servo and its driver on the right side rear of the machine with a pair of 40 tooth gt2 pulleys and a belt about 5" center to center from its mounting just inside the frame on the right rear. And I intended to use one of the nema 17,42 series stepper/servo's to move X on a linear bearing bolted to a 20mm square cf tube in place of the heavier alu extrusion. I'll of course have to build a hotend from pieces, using the knowledge of what needs fixed I've already gained.

But... The x home switch fell apart while trying to fix a clog, and apparently my $200 soldering station blew the printers mobo, a robin nano V1.2. So I ordered what I thought was 3 of those mobo's from amazon. but they shipped me V3.1's and the pin files don't match. Two Trees is supposedly shipping me a new V1.2 thru amazon which will take weeks if history is any indicator. So I've ordered a cnvoron trident I should have around the 3rd week of this month.
I need speed and it claims to be 4x faster that the Sapphire 5's 60mm.

I have designed a vise screw, and wrote the code to carve it from a hard maple stick, which w/o a tool changer on my much modified 6040 cnc mill takes about 2 days a 2x2 stick made into a screw. But on a prusa mk3s+ its around 2 weeks to make the printed nuts and the rest of it, if I could keep the prusa running, ready to be bolted to the bottom of a woodworkers workbench.

No one else has done this in around 100 years, so used, poorly designed stuff is selling at $200 and up on ebay. This one is stronger than those, and maybe faster to use. So I intend to see if there is a market for them.

But at 2 weeks a screw to make the petg parts, that slow printer speed must be dealt with.

I also have a tronxy-400-pro which came with a broken marlin so its never printed anything, so the motors will be stepper/servo's and the flying weight will be cf tube when I'm done with its rebuild. tronxy has effectively zero support, is designed to waste time till the warranty expires. So it is a framework to build a 400x400x400 printer that sold for $800. It will need diagonal bracing to go 300mm/sec, but I expected that.

My experience with the Marlin's bowl of spageti code is less than satisfactory, so the next builds will investigate klipper. I've a pile of bpi5's to do that with. They, and old rock64's run octoprint just fine, but the video out an old rock64 is visibly quite noisy where the bpi5 works fine.

Enough of my sob story, but I'm all ears if someone has some experience running the Robin Nano V3.1 on a corexy printer. With TMC2209 drivers.

Thanks all, take care, stay warm and well.

Some armbian update must have silently fixed that, it is now working to put a file in the watched directory specified. I've kept the bpi5 updated is all I can see as having fixed it. I have done nothing else to octoprint. I have updated the Marlin in the printer looking for a config that actually works, but that shouldn't be construed as fixing the problem I originally posted about. But I've now put 2 files in the watched directory, one with mc and one by direct from cura, and both worked, they're named a bit differently and both are now it the printer queue.

Thank you Charlie, you gave me the impetus to recheck.
Take care, stay well and warm.

Cheers, Gene Heskett.

"There are four boxes to be used in defense of liberty:
soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author, 1940)
If we desire respect for the law, we must first make the law respectable.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.