Watched folder doesn't run as well

Hello community,

today I've installed OctoPrint in the SD-Card of my Pi (3B+ I guess).
I wanted to create a watched folder to get my .gcodes easily to the printer.

So I've installed samba and samba-common-bin. In the /etc/samba/smb.conf file I've wrote a line wins support = yes under the default comment line workgroup = WORKGROUP
Also I've pasted this at the end of the file:
comment = Watched Folder
path = /home/pi/.octoprint/watched
browseable = Yes
writeable = Yes
only guest = no
create mask = 0777
directory mask = 0777
public = no

After saving the file an creating a passwd, i connected the pi inside my file system in windows and saved the connection.

Finished that work I tried to test it by opening a simple .stl file in my Slic3r create a gcode and export it to the watched folder and nothing is happend but seeing the gcode inside the watched folder, witch should always be empty. I tried that a lot of times always with the same result.
I've read that the samba support is off by default on win 10, so I've enabled it and because it bored me to use every time the Slic3r software i saved the gcode on the desktop.
After rebooting the system i tried to get the gcode in the watched folder with drag and drop from the desktop and it disappear after 5 seconds and uploaded to OctoPrint every time I tried it.
But again exporting the gcode directly from the Slic3r to that folder it will stay inside and get not uploadet to the OctoPi, it works manually buy clicking thought it but not as expected.

Does someone else got this problem?
Why it works after saving somewhere else but not after export from slic3r to the folder?
Is it because OctoPrint doesn't like Slic3r or Slic3r OctoPrint?
I've downloaded the latest version of OctoPrint today an updated && upgraded it, Slic3r version is also win 10 is on latest version

Hello @alex1!

You may search this forum for watched folder. There a quite some threads...

Hello @Ewald_Ikemann!

thanks for your fast answer. I've searched half of the web up and down about the first 2 sties of hits on google about watched folders, samba clients and octoprint and also on this forum i did not found something helpful for now.
Also tried to find something useful on youtube...

If you know a helpful thread please send me a link

I guess you already tried to activate active polling?

1 Like

wow, just can't believe that is that simple to fix the issue.

thank you @PrintedWeezl for that helpful answer