Web Browser crashing when loading Gcode Viewer of Vase mode prints

First hello everyone and thanks for Octoprint, it's been amazing to use since I installed it!

What is the problem?

When loading the 'Gcode Viewer' view of a vase mode gcode, it loads for a while and then crash the web browser page. I get an Error 'Out of Memory'.
image

The issue appeared in version 1.10.0
I waited for 1.10.1 and saw some bug correction related to gcode viewer but unfortunately it did not fix my issue.

What did you already try to solve it?

I tried multiple browsers, and multiple PC.
On Chrome and Edge it is always crashing.
On Firefox it works on smaller vase gcode but crashes on bigger one.

Same behavior from 3 different computers.

Have you tried running in safe mode?

Yes I tried.

Did running in safe mode solve the problem?

No, problem is still present in safe mode

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Normal_Mode_octoprint-systeminfo-20240516152746.zip (90.4 KB)
Safe_Mode_octoprint-systeminfo-20240516152833.zip (94.7 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system

OctoPrint version: 1.10.1
OctoPi version: Not applicable, running on Ubuntu
printer: MK3s+
firmware: 3.13.3 Revo
browser: Tried on Chrome/Edge/Firefox
operating system: Ubuntu 22.04.3 LTS

Can you share the gcode file?

Sure, here are some of them!

Tetrahex Ripple Vase_0.6n_0.4mm_PLA_MK3S_4h6m_171g.gcode.zip (693.7 KB)
HexagonRockCandy_Vase_0.6n_0.15mm_PLA_MK3S_4h51m_78g.gcode.zip (2.8 MB)

And this last one was showing fine in the gcode viewer before the update. Now it's crashing as well.

Glitch Planter x1.5 - Vase Mode Only_0.8n_0.55mm_PLA_MK3S_1h17m_71g.gcode.zip (300.3 KB)

Thanks!