Web Cam not working after 1.5.0 and 1.5.1update

Raspberry Pi Camera Module V2-8 Megapixel,1080p (RPI-CAM-V2)**

WebCam tab in the Octoprint main display window not working or streaming any video after I installed the new Ocotprint firmware 1.5.0**

I went into the settings menu, clicked on Webcam & Timelapse, then clicked on "Test", and it shows the stream working** I can see the print head moving as it prints the project. However, every time I click on the webcam tab nothing at all shows. I thought maybe the program got corrupted somehow so I removed the SD card from the Raspberry Pi, formatted it again in Fat32, re-installed Octoprint, set up all of the addons I had been using before, and it still is not showing the stream in the Webcam tab. But yet again it shows it when I go to the settings - Webcam & Timelapse tab. I can even see the steam through my iPhone and the Access Anywhere The Spaghetti Detective.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support) I have no idea how to get these log files
Additional information about your setup (OctoPrint version, OctoPi version, ...) When I re-installed Octoprint I entered the Raspberry Pi through Putty, changed the user name and password as instructed, activated the camera. I wanted to recheck that the camera was activated but keep getting "Access Denied" when trying to login to the Raspberry Pi using Putty.

1 Like

I had a similar problem with losing the image on my Pi Cam V2 on a RpI4 8 gig running Octoprint1.50 immediately after I moved the location of the camera from the top rail to the x axis. The move involved taking the cameral out of the old printed case and putting it into a new one. I didn't shut the system down because I wasn't going to connect/disconnect anything but that may have been where it all started for me. In the new location I got no video. I started connecting and disconnecting stuff and got disoriented with the cables. I tried new cables and a new Pi Cam. Also think the onboard cable became unplugged when I switched the cases and I didn't realize the camera is simply stuck on to the PCB and has a very short cable that plugs into a socket on the back of the PCB. Anyway, once I got the cable orientation correct and the camera plugged in I still didn't have video. Then I started looking at the firmware. To get to the video log for the webcam you need to use ssh to log into your Pi from a computer. Gina posted the command line in a thread a while back but as I recall you have to type "cat" or something like that in front of the line she posted. I dug around for a while and found a response by her to a neophyte like me that listed the exact wording of the line to get the webcam log file. Maybe some kind person will see this and confirm or correct. It would be nice if there were a resource out there with basic commands and programming guides for ?python? or whatever machine language this is. I remember the good ole days when all we had was basic. Now there are so many programming languages its like the tower of babel. Anyway, I digress. My point in replying is to say I read where when you reimage your Octopi software onto an SD card you are not supposed to format the card first. Simply image the card with Etcher and install in onto your Pi. Beforehand I would shut everything down and check all your cables, including the one on the camera pcb. you can lift it off with your thumbnail opposite the side of the camera and then snap it back on just to be sure. make sure you feel it snap in tightly. Then look down into the socket on the camera and on the Pi and make sure you know which side the little wires are. Make sure the metal contact side of the ribbon is against the wires, the ribbon is firmly inserted straight in and doesn't move while clamping the cable in. Then insert the SD and reboot. That is what finally worked for me. I'll dig around and see if I can find the exact line to get your webcam file. It didn't help me. I just think there is a certain sequence you have to follow in setting up the cam to get it to work right.

If you like, you may format your SD card several times: It would make no sense:

Formatting a storage device is not only deleting data (this actually does not happen when you fast format). The main purpose of formatting is to setup a file system on that storage device.

"Buring" a ISO file onto a storage device is different than just copying files.
When you burn, reimage or how else people call it, a ISO file to a storage device, everything that is on the original device is copied onto the new one. And I mean everything: Data, file structures, directories etc. This is why you have two directories on a SD card after you burned OctoPi onto it. A fat directory, and a Linux directory that can't be read by windows.
Also During burning a ISO file everything is erased/overwritten. Also the information you setup during the formatting you did before.
This is why formatting a storage device before burning a ISO image to it makes no sense.

1 Like

Just to clarify the termini here: a fat partition and a Linux partition.


And to further clarify, the FAT partition does not have a weight problem; FAT is an acronym for File Allocation Table.