Web interface doesn't load

What is the problem?

I installed Octopi 0.18.0 on a RaspberryPi 3B. Initial setup and first log in worked fine. I successfully printed a file using the web interface. After the print completed, I tried to log in again and found that it hangs at "Loading OctoPrint's UI, please wait...".

What did you already try to solve it?

Tried to log in with Firefox and Chrome (same behavior).
Tried clearing browser cache.
Tried running octoprint serve --debug to look for obvious errors.

Have you tried running in safe mode?

Yes, same results.

Did running in safe mode solve the problem?

No.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

The web console in Firefox shows:

Finalizing application startup packed_core.js:1022:243
Uncaught TypeError: OctoPrint.settings is undefined
    requestData http://ender3.lan/static/webassets/packed_core.js?22357642:245
    fetchSettings http://ender3.lan/static/webassets/packed_core.js?22357642:1022

The web console in Chromium shows:

Finalizing application startup
packed_core.js?22357642:245 Uncaught TypeError: Cannot read property 'get' of undefined
    at SettingsViewModel.self.requestData (packed_core.js?22357642:245)
    at fetchSettings (packed_core.js?22357642:1022)
SettingsViewModel.self.requestData @ packed_core.js?22357642:245
fetchSettings @ packed_core.js?22357642:1022
setTimeout (async)
(anonymous) @ packed_core.js?22357642:1022
c @ packed_libs.js?ab739628:1
fireWith @ packed_libs.js?ab739628:1
l @ packed_libs.js?ab739628:1
(anonymous) @ packed_libs.js?ab739628:1
load (async)
send @ packed_libs.js?ab739628:1
ajax @ packed_libs.js?ab739628:1
OctoPrintClient.ajax @ packed_client.js?613f819d:7
OctoPrintClient.ajaxWithData @ packed_client.js?613f819d:7
OctoPrintClient.post @ packed_client.js?613f819d:7
OctoPrintClient.postJson @ packed_client.js?613f819d:7
OctoPrintBrowserClient.passiveLogin @ packed_client.js?613f819d:38
LoginStateViewModel.self.requestData @ packed_core.js?22357642:159
onServerConnect @ packed_core.js?22357642:1022
(anonymous) @ packed_core.js?22357642:1022
c @ packed_libs.js?ab739628:1
fireWith @ packed_libs.js?ab739628:1
s.<computed> @ packed_libs.js?ab739628:1
DataUpdater.self._onConnectMessage @ packed_core.js?22357642:834
(anonymous) @ packed_client.js?613f819d:14
Pn @ packed_libs.js?ab739628:1
(anonymous) @ packed_libs.js?ab739628:1
OctoPrintSocketClient.propagateMessage @ packed_client.js?613f819d:14
(anonymous) @ packed_client.js?613f819d:21
(anonymous) @ packed_libs.js?ab739628:1
_t @ packed_libs.js?ab739628:1
(anonymous) @ packed_libs.js?ab739628:1
(anonymous) @ packed_libs.js?ab739628:1
onMessage @ packed_client.js?613f819d:21
r.dispatchEvent @ packed_libs.js?ab739628:1232
(anonymous) @ packed_libs.js?ab739628:1232
w._transportMessage @ packed_libs.js?ab739628:1232
i.emit @ packed_libs.js?ab739628:1232
ws.onmessage @ packed_libs.js?ab739628:1232
6The resource <URL> was preloaded using link preload but not used within a few seconds from the window's load event. Please make sure it has an appropriate `as` value and it is preloaded intentionally.

octoprint.log (254.8 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

This is a fresh install of the Octopi 0.18.0 image. After first login, it performed some self-updates.

pi@octopi:~ $ oprint/bin/octoprint --version
octoprint, version 1.5.3
pi@octopi:~ $ cat /etc/octopi_version 
0.18.0

Firefox version 78.9.0esr (64-bit)
Chromium version 88.0.4324.182 (Developer Build) built on Debian 10.8, running on Debian 10.9 (64-bit)

Hello @aradian !

Have you tried to lower the safety settings for octopi.local or that certain IP address of the Pi in FireFox?

Thanks for the quick reply!

Could you point me to some info on how to do that?

I haven't changed any browser settings between the time when it worked and when it didn't, but it might be worth trying anyway.

When you click tools in FireFox, you get this:

With Manage Exceptions you can add URLs and IP addresses for lower security.

Ok. Mine is set to standard. I also tried turning tracking protection off completely for the octopi host, but still got the same error.

Something in the JavaScript file has ended up broken. The settings stuff really does exist, so whatever it's ended up as under your instance seems to be broken.

Try force-reinstalling OctoPrint to see if it works.

~/oprint/bin/pip install --force-reinstall --no-cache-dir --no-deps octoprint

Other than that, we have seen browser extensions interfere, but you have tried it in multiple browsers - do they all have the same extensions?

Last night I wiped the sd card and wrote a fresh octopi 0.18 image to it. After going through the setup, printing several files, and logging out and back in at different times, everything seems to be working fine. The only difference from the previous (broken) install is that I've left the webcam disconnected. It's an IR cam that uses the RPi's camera port. Maybe there was some kind of hardware issue?

I'll try reconnecting it later today.

I doubt it, it looks to me like part of the static files for the UI went wonky. The camera shouldn't affect those.

After connecting the camera and running a couple more prints, everything still works fine. ¯\_(ツ)_/¯

At this point it seems unlikely that there's an actual bug to be fixed. Thanks for the help!

1 Like