Web interface unavailable or unresponsive

I'm facing a weird issue with my web interface.

Usually on server start or restart the web interface is available. It takes some time for it to load although my telegram plugin messaged me the online status minutes ago.

Nevertheless, when I start a print I usually close my octoprint tab to keep a clean browser. When I want to access my web interface it starts loading and abort with the following error:

Socket connection failed. Please check prior messages and 'octoprint.log' for possible reasons.

I do/did check the octoprint.log with results similar to this:

2020-05-12 09:32:23,917 - octoprint.server.util.sockjs - INFO - New connection from client: ::ffff:192.168.3.84
2020-05-12 09:32:39,314 - octoprint.server.util.flask - INFO - Passively logging in user klammerson from ::ffff:192.168.3.84
2020-05-12 09:32:39,518 - octoprint.access.users - INFO - Logged in user: klammerson
2020-05-12 09:32:40,432 - octoprint.server.util.sockjs - INFO - Client connection closed: ::ffff:192.168.3.84

Thats it. No error log. No other info. The web interface just keeps on throwing the mentioned error.

A restart of the octoprint server or the pi itself is necessary to access the web interface again. Sometimes I even need to restart the server more than once.

OctoPrint latest stable version
OctoPi latest stable version
Geetech A10 with Marlin 2.0.0
Browser: Safari, Chrome, Firefox

I'm using a Raspberry Pi Model B Plus Rev 1.2 and while printing the CPU usage runs at 100% with not more than 50% of RAM usage. Maybe this could be an issue!?

I'd be happy if you could assist. Thanks in advance.

That sounds like your Pi is so busy feeding the printer that it cannot react to the socket connection fast enough and the frontend then assumes something went wrong.

In 1.4.1 there will be the option to increase the timeout for this initial request. For now I suggest to either keep the tab open, reduce the number of installed plugins or just get a current pi model because yours is somewhat outdated anyhow and your experience in general would greatly improve with a Pi 3.

My new Pi arrived today and what should I say???
Thanks for your support anyways.
You are doing an amazing job around here!

1 Like

I'm having similar issues on not very complicated prints. with 1.4.0 after few hours of printing I can't connect to it over the network, wifi in my case. Using a Pi4b. To rule out hardware I rebuilt with OctoPi and did a few long prints with no issues.

for 1.4.0 I did a manual installation per the instructions on the community post.
for 1.3.12 I'm using OctoPi 0.17

for now 1.3.12 works fine for me as I was also having issue with OcotHue on 1.4.0 not activating.

Providing this info in case it helps diagnosing or other.

thanks,

Ron