Web Interface Won't Load, Can't SSH

What is the problem?

I haven't used my OctoPrint server in about a month, and not the web interface won't load, nor can I SSH into my Pi.

What did you already try to solve it?

I SSH'd into pi@octopi.local with default password "raspberry" I even tried the other usual default type passwords like admin, pwd, password, etc. No luck. As recommended in another thread, I put a txt file on the SD card named octopi-password.txt with a new password, and that didn't work either. I've also tried using the local IP address instead of octopi.local. No luck.

Have you tried running in safe mode?

No, I can't get into the server to restart it. All I can do is pull the power plug and reinsert it.

Did running in safe mode solve the problem?

No, see above.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

I'm not sure, I can't log in to confirm my current version.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Ender 3 Pro, Windows 10

Unfortunately, there isn't enough information here for us to provide much more than sympathy.

What version of OctoPi? What model Raspberry Pi? Are you connecting via WiFi or with an ethernet cable? If WiFi, can you try with an ethernet cable?

What error messages do you get when you try to SSH? Can you ping the IP address? What does nslookup octopi show? What does nslookup octopi.local show?

Can you attach a monitor to the Raspberry Pi and watch the boot sequence?

If you have pulled the power plug on the Raspberry Pi to shut it down, there's a non-zero probability that the microSD card has been corrupted. If you have another microSD card, it might be useful to start over.

Thanks, yeah, I figured there wasn't enough information. I was able to load the SD card into my windows PC and read the files with Disk Internals Linux Reader. The thing that was most valuable to me was some of the gcode files I had saved on there. I of course have STLs for everything, but I think I had a couple previous versions of models that I don't have STLs for.

In any case, I recovered my gcode files and reinstalled OctoPrint. I needed to do it anyway cause I haven't been able to install OctoLapse for some reason. After a fresh install it worked.

I'm still not sure what the issue was. To my knowledge power hadn't been pulled from the device prior to when I hard reset it. The OctoPi was connecting to my wifi network. I could ssh into it for log in, but no passwords were working. I did recover the old log file. I can post it later for your curiosity/posterity if you're interested. It looked like it booted without issue, but idk enough about that. I think it may have hung somewhere in the boot sequence.

Anyway, a fresh install did the trick. For anyone else who may be afraid to reinstall, you can recover your STLs using third party software if you don't have access to alinux machine.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.