Web server down

This problem has started happening recently, after working fine for a fairly long time. I do not recall doing anything new before it started happening.

The problem is simply that sometimes I go to look for the Octopi and it isn't there: no web page, no response to ssh or ping.
Possibly the whole system has crashed, or has just come disconnected from the network: I'm not sure how to tell.

What is the problem?

The Octopi Web page returns:

Unable to connect
An error occurred during a connection to

ssh: "connect to host port 22: No route to host"
Ping gives: "Destination Host Unreachable"

What did you already try to solve it?

If I switch it off and on again, it comes back up. Stays up for a while: sometimes hours, sometimes days.

Have you tried running in safe mode?

Not so far.

Did running in safe mode solve the problem?

Problem is intermittent, so would be hard to tell.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20230317090256.zip (1.9 MB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Rasbian V10
Octoprint V1.8.7

Have you tried looking at it using a local HDMI and keyboard ? If so, what do you see, do you get the command prompt or Raspbian UI? Can you log in?

Note that it is really not good just just power down a Pi by just power cycling it. Some times it can not be avoided but it will eventually cause some corruption to the info on the SD card. Might happen the first time you do it. My go unnoticed until well you start to see random issues.


Have you tried looking at it using a local HDMI and keyboard ?

It isn't easy to do that because of where it is at. If it comes to it, then that's what I'll do, but I would think there is an answer in the logs, if I knew where to look.

Note that it is really not good just just power down a Pi by just power cycling it. Some times it can not be avoided...

Yes, I am aware of that, but I couldn't see how to avoid it.
I must fit a reset button... and back up the data, not necessarily in that order.

System logs are in /var/log

Some RPi systems are prone to WiFi connectivity issues. Updating the system (sudo apt update && sudo apt upgrade) so that you have the latest drivers sometimes helps. Changing the WiFi channel sometimes helps (and if it used to work and now doesn't work, some other new WiFi signal could be the reason).

In OctoPi losing network connection mid-print - #88 by egar is a script that can be used to reset the WiFi interface. Add an entry to crontab:

# Crontab entry:
# */5 * * * * /home/pi/scripts/netcheck.sh > /dev/null 2>&1

I knew that, but where in the logs do I need to look? And what would I be looking for?
I don't have much of a clue...

Yes, I do do that reasonably often.

I don't think there is anything new.

I don't think it has happened mid-print, but I'll have a read of that thread, thanks.

It just happened again, but this time I was able to access the router to have a look: it showed the Pi as connected.
After poking around inside the router, looking for a helpful looking button to press, and finding nothing, I looked back and found it was working.
The only thing I actually changed was the icon, and I doubt that was what sorted it...

The "symptom" of that topic was a loss of connection during a print but the solution script has nothing to do with printing and everything to do with loss of connection.

Changing WiFi channels may help. Google "WiFi analyzer" and you can check if there is a better channel to use than the channel you are using now.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.