Web UI connects when my OctoPi is on LAN but not wifi

What is the problem?

I can access the OctoPrint UI on my browser just fine when my OctoPi is connected to my network over LAN, but when I switch to WiFi and try to connect using the wifi IP address, it redirects to the OctoPrint Login and tries to load it but it just stays a blank screen for a few minutes and then says it can't connect. Again, it all works perfectly when my OctoPi has a wired connection, just not when it has a wireless connection. I've tried the solutions below, but no luck. Does anyone have any insight?

Note: I'm using a Libre Computers Le Potato instead of a Raspberry Pi due to the current Raspberry Pi shortage.

What did you already try to solve it?

  • Updating the wpa-supplicant file
  • Using a different router
  • Setting a reserved IP address
  • Using multiple different OctoPrint installation methods (currently set up through OctoPrint_Deploy)
  • use ifmetric to change the priority network to wlan0 instead of Ethernet.
  • Checking the raspi-config settings to make sure I have the correct country and timezones and everything.

Do you know that your Potato is even connected to the WiFi network? If you are actually seeing the OctoPi log in screen, I’d guess that you are (unless it somehow has a a cached copy?)

The instructions here might help (though it’s possible you have a different problem):

I can ping Google from it and ssh into it so it's definitely connected to WiFi. I think the issue is either a privacy/security/system settings issue or I've seen things about connecting directly to a WiFi/Modem combo, and the standalone router I tried was a Wireless G router I found in my parents' house, so it may be that switching routers caused two different issues that led to the same outcome and just I need to pick up Wireless AC router and try it that way. Before I go buying hardware, do you know of any router or Raspian settings that could cause the connection failure over privacy/security/system settings?

I think I'm currently going through a similar issue, and for me the problem is my local network topography, not the pi's settings (though I haven't completely solved the issue).
Have you been doing your testing from a device that's also plugged into ethernet? If so, try connecting via a device on wifi (for me this just meant unplugging my laptop's ethernet cable).
I was then able to access the WebUI. That suggests there was nothing wrong with the Raspian settings, but rather that something on my network is preventing me from accessing the webUI, but not blocking SSH ports. Appolgies if this doesn't help at all, but at least it's a quick thing to test.

I can't access it over WiFi through my laptop either, so the issue has to be somewhere between my Pi and my router. I got a new router the other day that I haven't set up yet so hopefully once that's set up it'll solve the issue, but for now I'm kinda stumped. Please let me know if you finish solving your issue and I'll keep you updated if the router swap works.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.