Webcam config IR / same configs different behavior

What is the problem?

Setup of 2 indentical pi3b+ w/ picam IR with 2 SD cards running octoprint 1.3.11 :
#1. SD card w/ a legacy install
#2. SD card w/ a new install and backuped octopi configuration from card #1

both SD cards have the indentical config.txt and octopi.txt in /boot/

Pi running w/ SD card #1 has night vision truned on automaticly.
Pi running w/ SD card #2 night vision is turned of.

Changnig the cards changes the behavior of the pi's according to the cards.

Any clues what else to try?

What did you already try to solve it?

Set up discribed above.

Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...)

octopi.txt:

camera="raspi"

and

camera_raspi_options="-x 1280 -y 720 -fps 15 -quality 95 -hf -vf"

set.

pi SD Card 1:

systemctl status webcamd
● webcamd.service - LSB: webcam daemon
   Loaded: loaded (/etc/init.d/webcamd; generated; vendor preset: enabled)
   Active: active (running) since Sun 2019-10-20 12:33:48 BST; 12min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 998 ExecStop=/etc/init.d/webcamd stop (code=exited, status=0/SUCCESS)
  Process: 1006 ExecStart=/etc/init.d/webcamd start (code=exited, status=0/SUCCESS)
    Tasks: 13 (limit: 4915)
   CGroup: /system.slice/webcamd.service
           ├─1014 /bin/bash /root/bin/webcamd
           └─1029 ./mjpg_streamer -o output_http.so -w ./www  -i input_raspicam.so -x 1280 -y 720 -fps 15 -quality 95 -hf -vf

Oct 20 12:33:48 octopi mjpg_streamer[1029]: MJPG-streamer [1029]: resolution........: 1280 x 720
Oct 20 12:33:48 octopi mjpg_streamer[1029]: MJPG-streamer [1029]: camera parameters..............:
Oct 20 12:33:48 octopi mjpg_streamer[1029]: MJPG-streamer [1029]: www-folder-path......: ./www/
Oct 20 12:33:48 octopi mjpg_streamer[1029]: MJPG-streamer [1029]: HTTP TCP port........: 8080
Oct 20 12:33:48 octopi mjpg_streamer[1029]: MJPG-streamer [1029]: HTTP Listen Address..: (null)
Oct 20 12:33:48 octopi mjpg_streamer[1029]: MJPG-streamer [1029]: username:password....: disabled
Oct 20 12:33:48 octopi mjpg_streamer[1029]: MJPG-streamer [1029]: commands.............: enabled
Oct 20 12:33:48 octopi mjpg_streamer[1029]: MJPG-streamer [1029]: starting input plugin input_raspicam.so
Oct 20 12:33:48 octopi mjpg_streamer[1029]: MJPG-streamer [1029]: starting output plugin: output_http.so (ID: 00)
Oct 20 12:33:48 octopi mjpg_streamer[1029]: MJPG-streamer [1029]: Starting Camera

/var/log/webcamd.log

Starting up webcamDaemon...

--- Configuration: ----------------------------
camera:        raspi
usb options:   -r 640x480 -f 10
raspi options: -x 1280 -y 720 -fps 15 -quality 95 -hf -vf
http options:  -w ./www-octopi -n
-----------------------------------------------

<13>Nov 13 14:02:43 pi: Starting Raspberry Pi camera
Running ./mjpg_streamer -o output_http.so -w ./www-octopi -n -i input_raspicam.so -x 1280 -y 720 -fps 15 -quality 95 -hf -vf
MJPG Streamer Version: git rev: ddb69b7b4f114f3c2ca01adf55712792ca8aed43
 i: fps.............: 15
 i: resolution........: 1280 x 720
 i: camera parameters..............:

Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'

SD card 2#:

pi@octopi:~ $ systemctl status webcamd
● webcamd.service - LSB: webcam daemon
   Loaded: loaded (/etc/init.d/webcamd; generated; vendor preset: enabled)
   Active: active (running) since Sun 2019-10-20 12:44:20 CEST; 1h 2min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1406 ExecStop=/etc/init.d/webcamd stop (code=exited, status=0/SUCCESS)
  Process: 1415 ExecStart=/etc/init.d/webcamd start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/webcamd.service
           ├─1422 /bin/bash /root/bin/webcamd
           └─1437 ./mjpg_streamer -o output_http.so -w ./www  -i input_raspicam.so -x 1280 -y 720 -fps 15 -quality 95 -hf -vf

Oct 20 12:44:20 octopi mjpg_streamer[1437]: MJPG-streamer [1437]: resolution........: 1280 x 720
Oct 20 12:44:20 octopi mjpg_streamer[1437]: MJPG-streamer [1437]: camera parameters..............:
Oct 20 12:44:20 octopi mjpg_streamer[1437]: MJPG-streamer [1437]: www-folder-path......: ./www/
Oct 20 12:44:20 octopi mjpg_streamer[1437]: MJPG-streamer [1437]: HTTP TCP port........: 8080
Oct 20 12:44:20 octopi mjpg_streamer[1437]: MJPG-streamer [1437]: HTTP Listen Address..: (null)
Oct 20 12:44:20 octopi mjpg_streamer[1437]: MJPG-streamer [1437]: username:password....: disabled
Oct 20 12:44:20 octopi mjpg_streamer[1437]: MJPG-streamer [1437]: commands.............: enabled
Oct 20 12:44:20 octopi mjpg_streamer[1437]: MJPG-streamer [1437]: starting input plugin input_raspicam.so
Oct 20 12:44:20 octopi mjpg_streamer[1437]: MJPG-streamer [1437]: starting output plugin: output_http.so (ID: 00)
Oct 20 12:44:20 octopi mjpg_streamer[1437]: MJPG-streamer [1437]: Starting Camera

/var/log/webcamd.log

Starting up webcamDaemon...

--- Configuration: ----------------------------
camera:        auto
usb options:   -r 640x480 -f 10
raspi options: -fps 10
http options:  -w ./www-octopi -n
-----------------------------------------------

<13>Nov 13 14:02:47 pi: Starting Raspberry Pi camera
Running ./mjpg_streamer -o output_http.so -w ./www-octopi -n -i input_raspicam.so -fps 10
MJPG Streamer Version: git rev: ddb69b7b4f114f3c2ca01adf55712792ca8aed43
 i: fps.............: 10
 i: resolution........: 640 x 480
 i: camera parameters..............:

Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'

topic solved by roll back to backup

1 Like