Webcam doesn't work with http, but ok with https

Raspberry 3B +
64Gb SD card loaded using octopi-buster-lite-0.17.0
Windows 10 workstation
browsers: Edge, Chrome and Vivaldi

For a year, I used, without any problem, Octopi to follow my 3D prints with a Logitec C920 camera, but since the update (installed version = 1.3.12) it no longer works in video mode.
The snapshot test is ok, but the streaming test fails.
I browsed the forum and found that I am not the only one experiencing this problem.

To fix this trouble, I reinstalled from scratch octopi, but I need to do some manipulation to get streaming works.

I finally discovered that if I call the site in ssl: https://octopi.local/ then I am blocked by the browser (chrome, Vivaldi or Edge) which considers that the certificate is invalid [err: DLG_FLAGS_INVALID_CA
DLG_FLAGS_SEC_CERT_CN_INVALID], but if I ignore this warning, then streaming works. :smile:

To obtain streaming operation with an insecure http connection, I modified this parameter: setting> Webcam & Timelapse> stream URL as follows: https://octopi.local/webcam/?action=stream instead of webcam /?action=stream

In order to be able to use the https connection, without the browser rattling, I added (with certmgr.msc) the certificate returned by the server, but it has no effect, the certificate is still declared invalid.

How can I prevent the browser from bitching about the certificate returned by the octopi server? Which certificate authority should I declare?

Good Christmas. :champagne: