Webcam in Windows

Hello, I am running octoprint on Windows and it works correctly, however the webcam is not working as it should, when I open octoprint it works for a few seconds and stops transmitting, I directly enter the stream link and exactly the same thing happens, I don't know how to configure it, I used the windows installer.
Thanks in advance for your help

which camera option did you use when installing? recent versions of the installer have either YawCam or go2rtc.

Make sure you are running a 16g sd card or higher.

give your streamer a higher priority;
sudo renice -15 -p $(pgrep 'camera-streamer')

If you are NOT running a desktop, give your system a "boost";
sudo renice -5 -p $(pgrep 'octoprint')

sudo renice -20 -p $(pgrep 'systemd')

All apps run at 0 priority by default.
A higher negative number gives it more processor time.

These are the numbers that I run with 3 cameras. Play with it.
Do not run all of them at -20, it'll freeze. -20 is highest.
"Systemd" is the executable of the OS. -20 is good.

You will have to enter these every time you boot up. I copy, tweak, and paste them out of Notepad++.

When you find numbers that work well, make the changes permanent (set on bootup):
sudo nano /etc/rc.local

scroll all the way down and insert your lines BEFORE the 'Exit 0".
ie;
sudo renice -5 -p $(pgrep 'octoprint')

sudo renice -15 -p $(pgrep 'camera-streamer')

sudo renice -20 -p $(pgrep 'systemd')

Exit 0

Good luck,
-JC

use go2rtc since it said it was newer :slight_smile:

Thank you very much but I don't know how to do it in Windows :slight_smile:

Ok, my bad. I got a little ahead of things.

On windows go download Putty. There are other programs, but lets try this one;
https://www.putty.org/
When people talk about SSH, this is what you use to communicate to the pi.
Run the program and at the top;
Host name (or ip address)
Enter: octopi.local and click on "Open".
A black screen will appear and ask for your ID and password. Enter your info.

If everything is good, you will have a prompt.

Copy and paste the "sudo" commands and follow the instructions.
Note: You might be prompted for your "sudo" password.

-JC

I think you don't understand me, octoprint is not running on a Pi, it is installed directly on Windows and runs on a PC :slight_smile:

OK. Sorry. Unfortunately, I know nothing anything about Octoprint for Windows.
I do know that if you are running windows 11, in the search type "camera privacy settings" and click on the app.

The window comes up and you have to give Octoprint access to the webcam.

-JC

Do you have UI customizer installed?

OK, thanks a lot :slight_smile:

I don't have it installed, do I need it?

no, you don't need it. was trying to determine if it was potentially interfering. If you go to http://localhost::1984/ and click Add at the top and then click ffmpeg devices(usb) what is listed?

I see the URL of the camera and the camera mic.

The transmission does work, but not as it should, when I try to see the transmission either from octoprint or from the URL directly it works for at least 10 seconds, then the transmission cuts off as if it will end then I have to reload the page and it transmits again but just for 10 seconds

I accidentally deleted the stream and now I don't know how to configure it

The default config is

ffmpeg:
  bin: "C:/OctoPrint/ffmpeg.exe"
streams:
  webcam1: ffmpeg:device?video=0#video=h264