Webcam is not streaming

Camera model


What is the problem?

No image, no video. Sometimes it works for a while, then for unknown reasons, stops (I realise that just before a print)

I got this error message for the first time while printing today:
HTTPConnectionPool(host='', port=8080): Max retries exceeded with url: / (Caused by NewConnectionError(': Failed to establish a new connection: [Errno 111] Connection refused'))

In the main octoprint setting page:
Path to FFMPEG is shown
Testing says The path is valid

Snapshot stream link says refused to connect

In classic webcam settings
Stream URL /webcam/?action=stream
and Snapshot URL at my device and port 8080 does not work

What did you already try to solve it?

Tried everything I could find online. Tried to reinstal image from when it was working but it doesnt work anymore. Seems that just removing the storage when powered down might trigger something, I dont know.
IC2 is enabled., Tried on off, same with legacy webcam in raspi-config.

I can actualy see that the cam is available and accessible:
libcamera-hello --list-cameras
Available cameras

0 : ov5647 [2592x1944] (/base/soc/i2c0mux/i2c@1/ov5647@36)
Modes: 'SGBRG10_CSI2P' : 640x480 [58.92 fps - (16, 0)/2560x1920 crop]
1296x972 [43.25 fps - (0, 0)/2592x1944 crop]
1920x1080 [30.62 fps - (348, 434)/1928x1080 crop]
2592x1944 [15.63 fps - (0, 0)/2592x1944 crop]

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle



Running PiHole and HomeAssistant on different docker containers
Octoprint and these work fine otherwise

OctoPod is configured, was working well with cam. Now, no cam, getting Error response HTTP : 503 for the link to the webcam streaming


I would appreciate help, I'm a beginner and searched a lot online to find a fix but cant seem to find anything. Thanks!

Hello @JPc !

Can you please attach the systeminfo bundle to you r next post.

Good morning,
I have the same problem, for a few days my picam no longer sends video.
I can't find the solution.
Here is my systeminfobundle.
Thanks for your help. (30.1 KB)

Hi, here it is: (41.9 KB)

After many tests with backups I had made, I narrowed it down to the IP address configuration.
octopi.local:5001 no camera is going through
Pi address 192.168.0.XX with no ports added enables the camera to go through
I don't know how the configuration was changed in my installation but it seems to be the only difference. And now it works. Hope this helps someone else

Edit: It might be a conflict with home assistant. Everything was good and -litterally overnight - after a clean install of home assistant (portainer), i can't access with octopi directly with no ports added, and camera is not streaming anymore, and same error message.