Webcam is unable to disable Autofocus

Good day! I am currently building a printer enclosure featuring octoprint, and I have problems controlling my webcam setting through SSH. I am not a great Debian programmer, I mostly follow online instructions and those have given great advice for my second printers C920 Webcam in the past. But this time I got myself another Webcam, one with an integrated LED from JIGA. A amazon link to the cam:ÅMÅŽÕÑ&dchild=1&keywords=webcam+ringlicht&qid=1614949694&sr=8-3

Now I tried the same commands as with the C920 through SSH being:

uvcdynctrl -s "Focus, Auto" 0

but this gives me an: ERROR: Unknown control specified.
So i checked with uvcdynctrl -c and focus is indeed not listed.
Similar problems with

sudo v4l2-ctl --set-ctrl=focus_auto=0

So i would be like "oh well, my webcam does not support the focus to be controlled in code, but i found a way using guvcview in some forums, said to enable additional commands to my cam. After installation however, if i do "sudo guvcview", I get a large error that i cant seem to resolve by myself as I lack experience. (1016 Bytes)

So my question: Am i missing something obvious here or is the answer just that i really should have just gotten another webcam that supports focus commands?

I appreciate every answer! :smile:
(Thats my first entry here and in gerneral in an online forum in a long time)

Did you find a solution to this? I had same error.