Webcam Issues - Stream URL

Camera model

Logitech C270

What is the problem?

I cannot get the stream to configure properly

What did you already try to solve it?

Tried to put in the stream URL Manually, Ran dmesg | tail -n 20 which resulted in ::
[ 9.377802] hub 1-1:1.0: USB hub found
[ 9.378169] hub 1-1:1.0: 4 ports detected

[ 9.913675] usb 1-1.3: new high-speed USB device number 6 using dwc2
[ 10.230669] usb 1-1.3: New USB device found, idVendor=046d, idProduct=0825, bcdDevice= 0.12
[ 10.230840] usb 1-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=2
[ 10.230938] usb 1-1.3: SerialNumber: 0DA6B410
[ 10.234494] usb 1-1.3: Found UVC 1.00 device (046d:0825)
[ 10.275315] input: UVC Camera (046d:0825) as /devices/platform/soc/c9100000.usb/usb1/1-1/1-1.3/1-1.3:1.0/input/input8
[ 11.654837] usb 1-1.3: set resolution quirk: cval->res = 384

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (7.8 KB)

Additional information about your setup

OctoPrint version :: latest, OctoPi version, printer Alfawise U30 :: System Odroid C2

When I reinstalled it twice it was just blank and the thing comes with a Classic Webcam Plugin? Dunno if that is any help

Did you use the new image with the new camera stack or the old?

Did you attempt to restore from a backup as well?

"Did you use the new image with the new camera stack or the old?" I dont understand what that is or how to enable it.

No i did not restore from a backup.

If you use the Raspberry Pi Imager program to create the SD card (preferable), when you choose the OctoPi image you are then allowed to select either the old default camera stack or the new camera stack.

The new camera stack is better and will work with your camera.

The Imager program permits you to set up your WiFi connection, Pi login name and password, SSID, WiFi Password, network name, country (very important for WiFi) and one or two other items so that the PI comes up properly and is recognized by your network.

I used a image that was inlcuded with a operating system called DietPi, because i dont actually have a raspberry Pi. Do i need to do something in order to change that. When i previously used it just to try the camera did work with the said image included with the system

I use a Odroid C2

That explains a lot.

Octoprint does not actually know how to deal with a camera, in spite of the fact that there is a built-in plugin for "classic" cameras.

In the OctoPi image one of two possible separate camera handling programs are baked into the image and ALMOST completely set up for you, so that in most cases if you only have one camera, the camera merely seems to work.

This fools people into believing that somehow Octoprint is doing all of the work so to speak. Instead the camera handling is performed by another program either the older "mjpeg streamer" or the newer "camera-streamer" program.

Since you are not using a Raspberry Pi image, you will have separately download and install one of the two streaming programs onto your device.

IMHO "camera-streamer" is the easier of the two to set up, and the Github page for camera-streamer provides instructions for non-RaspberryPi installation.

You can even test camera-stream to make sure it is working without even having Octoprint running, since it is completely independant of Octoprint. Not to add confusion, but the device that runs the streaming program can reside on a completely different computer on your network if you wish, but that is another matter.

Once you do have camera-streamer running properly you can tell Octoprint what the Stream "address" is as if it were just another user accessing the camera, and then Octoprint will display the stream imbedded into it's own web interface.

You can set up camera-streamer via a SSH command line connection or by hooking up a keyboard & monitor to your device that runs Octoprint.