Webcam not working


#1

What is the problem?
I plugin my USB webcam but it is not working when I try to access on the browser

What did you already try to solve it?
I´ve changed some configuration on octopi.txt

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Here is the information on /var/log/webcamd.log


#2

Also...here is the lsusb command:


#3

I assume you made the settings in the Webcam tab of the OctoPrint settings?


#4

To me, it looks as though your webcam and/or it's driver doesn't support YUYV and that's what mjpg-streamer is complaining about. What kind of webcam do you have?

Edit: pre-coffee spelling :rofl:


#5

Running ./mjpg-streamer -o output_http.so -w ./www-octopi -n -i input_uvc.so -r VGA 640x480 -f 10 -y -d /dev/video0
[...]
Could not obtain the requested pixelformat:YUYV, driver gave us S920

Looks you added the -y parameter in your octopi.txt (btw, next time please not only state that you "changed some config" but also what exactly :wink: ) but your camera doesn't support that one. I have no idea what "S920" is supposed to be with regards to a pixel format, so If it also doesn't support running without that -y parameter (read: in mjpg mode) your best bet might be to get a camera known to be supported.


#6

Hello Ewald, I´ve made on the URL of Webcam tab...change the default URL to /dev/video0 but I´m not sure if it´s rigth (still not working after this change).


#7

jajaja thanks for your reply jubaleth, I post my problem almost asleep!
YUYV could be a problem (I think about this), so I´ve tried with VGA on octopi.txt but still complaing.


#8

Hi foosel, thanks for your recommendation (sorry about my short explanation on the changes I´ve made in octopi.txt).
Yes, I´ve used -y parameter but the problem continue. So, I think this is related to my usb cam that´s not supported.
I´ll change it and try again.
Thanks!