Webcam powering on startup, then shuts off

Hey all, trying to get my webcam working.
It's a trust 14776 (have got VGA resolution set and 1fps with -y)

Problem is that once I power my RP3 B+ I see the led on it turn on, after few seconds it turns off and stays off.

I disconnected the webcam, and reconnected it again. Ran dmesg | tail -n 20 and I get this error

I recognise the devide ID/vendor from lsusb as my webcam, annyone knows how to solve this?
Since it powers off before I can get into the octopi.local there is no webcam.log file to want to upload.

Try it without your printer beeing connected.
It might be a power related problem.

tried doing that the first few tries. made no change sadly. I can redo it and make a new screenshot of the terminal output then if you want?

Checked with a powered usb-hub (connected to the pi) that it's not a power related problem.
The webcam still did axectly the same.

Stumbled upon this guide : made an attempt on doing this.
Startup now keeps the webcam on, but when trying to get the webcam to work (by going to the IP adress) I only get a green screen now. tried tinkering with the display settings / framerate etc : stays green. Annyone might know why?

It now states it supports the camera, but does not detect it. How is that possible if I can see it in lsusb?