Webcam slow LOGITECH C270

The video of the webcam is extremely low and has a lot of latency. About 10-15 second.
I have a Logitech C270

What did you already try to solve it?

I tried to put in octopi.txt different configuration:
"-r 1280x720 -f 30"
"-r 1280x960 -f 30"
"-r VGA -f 10"

no one is good, unfortunately.

Have you tried running in safe mode?

yes, but the webcam is disabled

Did running in safe mode solve the problem?


Systeminfo Bundle

[|attachment](upload:// (1.5 MB)


I have a FLSUN Q5. I use a power source of 5v 3A, officially raspberry. (1.5 MB)

Already tried the serach feature of the forum?

Hello dear, yes I tried multiple configurations, but it is so slow. 10-15 seconds of latency. If I try raspicam it is perfect. What can I do???

I put "camera_usb_options="-r HD -f 30"" and it worked perfecly

1 Like

NOPE. After reboot, the problem is stille here? What I'm missing?

Weird. Sometimes I reboot and it is perfect. Sometimes reboot and it is extremely laggy.

I'm going slightly mad

I cant really help, but I can confirm I have the same issue and I have had it with PI 3, 3+ and 4. I have tried many different parameters in the config file. It is not just you, you are not going mad!

Since I've got a new (usb) camera installed to replace my Pi Camera on my OctoPrint Pi I've been experiencing similar issues. Even a crash on rendering a time-lapse from a small print.
From what I've seen is that there was a frame-rate mismatch between the config in .octoprint/config.yaml and /boot/octopi.txt

I matched the frame-rates in both files, rebooted and it seems to be a bit better. Haven't tested with creating a time-lapse on prints yet but initially the ffmpeg stream and control tab feel smoother.

So you might want to check the frame-rates in your configuration files.

mates, thank you for your feedback. Indeed, after insane days of searching for a solution, I tried simply to connect the Rpi to an Ethernet adapter and then use a wire to connect it. The problem was definitely solved. The real thing that doesn't convince me is that with the Raspicam, wi-fi was sufficient and it worked without a single problem. Via USB there is something that Octoprint doesn't like, for sure. Thanks

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.