Webcam snapshot doesnt work

I have the following problem that I can not get a snapshot image externally.
if I do it internally in octoprint it works.

but i tried it with
(?action=snapshot)...but I don't receive any image....
the same when i enter in the browser this address:
i get as answer: has refused the connection.
where is the error ?

tthanks Marcell

What setup are you using? OctoPi?


browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.93 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1200
env.hardware.ram: 915058688
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x50005
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.2
printer.firmware: Marlin bugfix-2.0.x (Mar 27 2021

On OctoPi the webcam is accessible under http://<your-ip>/webcam/?action=snapshot, port 8080 is only available to the Pi internally.

Also while you're here:

Your Pi is power throttled and unstable, it is reporting undervoltage issues. You should get a better power supply.

Okay, i will fix that with the power supply.
But how can i get the snapshot from externally?

I gave you the URL;

If you mean outside your network, you will have to setup a remote access solution that will also provide you with the webcam feed.

no, i have a smarthome server (FHEM)
on another raspberry and I would like to send snapshot.
so I would be enough if I knew how I would receive an image.
i have now as path this :
but it does not work

just to be sure - there needs to be a port after the :
If you don't want to use a port, you have to remove the :

so the url should look like http://octopi/webcam/?action=snapshot

Thank you. I ll try it

Mhmm. I get this message - Verbindungsaufbau abgelehnt (111)

Connection rejected
Any idea? When I try this in the browser it works without credentials

Or do I have to enter additional credentials?

Okay, just to complete... Had all the time the port with specified. That's why it didn't work now with port. Without port it worked now everything.
Thanks for the great support

I also missed that in your last post :smiley:
Glad to hear it worked