Webcam Stream Loading and loading and loading

Noob Here, so go easy please :wink:

I have just installed a Raspberry Pi 3 Model B Plus Rev 1.3, along with a Pi Webcam 2.1. Installed all this to my Ender 3 pro printer, very well if i may say so for a noob.

However, i cannot for the lif eof me get a picture (Stram) out of the camera. Looked this up on google and it seems quite popular issue. Ran a few test and it seems my camera is detected by running the 'vcgencmd get_camera' cmd in SSH, but having confused myself no end by all the reading on the www, i am still getting no picture (stream) with just the text showing 'Webcam Stream Loading'.
I have also checked the as well but nuffing at all!

I have checked the connections twice and the ssh cmd result mentioned suggests that the Pi is seeing the camera, but i am not seeing what the camera is seeing...

Please offer this frustrated noob some help please? PLEASE!!

I have added the cura plugin and can print from cura, but again no steam is seen in cura.

HUGE THANKS you very clever people.

PS. Using 0.17 version of Octoprint (Latest)
Using wired connection, but also does not work over WiFi
Tried IE, Firefox and Chrome all showing same error or message
Latest log file uploaded.

octoprint (1).log (140.9 KB)


Thought i would try to see if i could see the stream on my phone after reading some more on the tinterweb, so i pt into my chrome phone browser (Android), http://myipaddress:8080, and IT WORKED, but the image was out of focus, so i went to focus the camera with the white round focus aid, and the image froze and then when i went back into the ip address again, i am now getting the same page i get on my PC .Nothing!
Now i am sure the same thing happened when i first setup the camera today, i am sure for a few secs i got a picture, but my printer room was in darkness, so i never saw a good image?

Could this be network related?

I am sure someone has had this issue out there in the ever growing 3d printing world, Please share your fix with me as i don't have much hair left LOL!


I give up with this damn camera. Its plainly obvious from the amount of post identical to mine that this is black magic and some work some don't and no one has a solid fix.
After posting my post to which 18 people have read but not commented, i rebooted the Pi and blinking flip it worked, did nuffing else, adjust nuffink, it just worked. So i attempted to focus the camera agin and it stopped working again. Another reboot and nothing, nada again!.

Left it a day in the off, and switched it on again and it's working now. 3 days of solid working, and now fully focused, i switch it on this morning and it is not flippin working again! Nothing was touched, nothing moved.

It's voodoo, black magic and the Pi gods are not with me today.

Damn Bloody thing!! Does anyone have a good reliable USB CAM option i can use?

Pi Cam..........PAH!!

PS. Sorry Mods, if you want to move this thread to the Webcam section, Dig out. When i posted the original, i did not know the structure of this forum, Apologies.


Bought a new Webcam, this time the black NOIR version, plugged it in and it just worked and worked. So now i have RaspiCam and Logo 270 both working.

1 Like


So could you please: PSA: Please mark the solutions to your topics as such

Will do Ewald_ikemann.

You clicked the link I attached?

Yes I certainly Did why? Am i missing something else?

You may click the check box:
Or is there none?