Webcam Stream Loading... Safari

Camera model

NexiGo N620E

What is the problem?

I often get the message Webcam Stream Loading on the control tab of Octoprint

What did you already try to solve it?

Messed with Obico's video options, turned that off and disabled it. Eventually solved the problem by switching to Chrome instead of Safari. Don't particularly like the solution.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Didn't try

Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.5.2 Safari/605.1.15
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1512.0
env.hardware.ram: 1031921664
env.os.bits: 64 linux
env.os.platform: linux
env.python.pip: 22.3.1
env.python.version: 3.9.2
env.python.virtualenv: True unknown
octoprint.last_safe_mode.reason: unknown
octoprint.safe_mode: False
octoprint.version: 1.9.2
printer.firmware: Prusa-Firmware 3.13.0 based on Marlin
systeminfo.generated: 2023-07-30T14:01:31Z
systeminfo.generator: zipapi


Additional information about your setup

Octoprint 1.9.2 running on an Orage Pi Zero 2 Via the Obico image. Updated everything.


This might be more of a web browser problem. I get "Webcam Stream Loading..." intermittently when I visit the Control tab in Safari. It's getting worse.

Time lapses, octolapses, Obico still work.

If I visit the Octoprint's Control tab in Chrome I get the video. Also in the Temperature tab I get overlays for when print started that I don't get in Safari.

I do keep chrome around for some compatibility but I don't like it - it's not energy efficient and it does too much tracking.

OK digging deeper. Clearing cache and quitting Safari fixes it.

Recreating the problem is easy. Opening two browser tabs with the Octoprint control tab corrupts the cache for the second video stream. You only get "Webcam Stream Loading..." on the second browser tab. It stays in cache after that.

Delete cache and restart Safari fixes it.

Chrome doesn't have a problem with two browser tabs both with Octoprint's Control tab. Octo streams to two there.

Looking a lot like a browser problem.

Could you please create a bug report here?

I'm not sure if foosel can do anything about it since she doesn't have a Mac system to test it on - so no promises here :slight_smile:

Done and I also submitted a bug report to Apple.

1 Like