Webcam Stream Not Loaded, Tried Everything

Camera model
Inland Camera Module 5MP 1080p
What is the problem?
Unable to get a camera to stream to octoprint
What did you already try to solve it?
Rather New so tried as much as I could find sooooo

Cant reach http://octopi.local:8080/

already ran

sudo apt-get update

sudo apt-get upgrade

sudo raspi-config

vcgencmd supported:1 detected: 0

already double checked all wiring, ribbon, got another camera in case it was a dud

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support) (71.6 KB)

journalctl -u webcamd:
octopi systemd[1]: Starting the OctoPi webcam daemon with the user specified config...
octopi root[492]: Starting USB webcam
octopi mjpg_streamer[493]: MJPG-streamer [493]: starting application
octopi mjpg_streamer[493]: MJPG-streamer [493]: MJPG Streamer Version: git rev: 5554f42c352ecfa7edaec6fc
octopi mjpg_streamer[493]: MJPG-streamer [493]: Using V4L2 device.: /dev/video10
octopi mjpg_streamer[493]: MJPG-streamer [493]: Desired Resolution: 640 x 480
octopi mjpg_streamer[493]: MJPG-streamer [493]: Frames Per Second.: 10
octopi mjpg_streamer[493]: MJPG-streamer [493]: Format............: JPEG
octopi mjpg_streamer[493]: MJPG-streamer [493]: TV-Norm...........: DEFAULT
octopi mjpg_streamer[493]: MJPG-streamer [493]: init_VideoIn failed
octopi systemd[1]: webcamd.service: Succeeded.
octopi systemd[1]: Started the OctoPi webcam daemon with the user specified config.
octopi systemd[1]: webcamd.service: Service RestartSec=1s expired, scheduling restart.
octopi systemd[1]: webcamd.service: Scheduled restart job, restart counter is at 1.
octopi systemd[1]: Stopped the OctoPi webcam daemon with the user specified config.
octopi systemd[1]: Starting the OctoPi webcam daemon with the user specified config...

/var/log/webcamd.log Permission Denied

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Additional information about your setup (OctoPrint version, OctoPi version, ...)
Raspi 4 B+ (12.1 KB)

I'm at a complete loss and as I am pretty new, even though I see the errors such as it not detected, init_VideoIn failed, lsusb not recognizing it, however its a IR camera and I can see the red glow coming off the leds, leading me to believe its a user error on my part, yet I have no clue what to do with that info

You aren't supposed to be able to reach port 8080. Try http://octopi.local/webcam/?action=stream instead.

Nothing below this is going to work until it's detected here. Check that both ribbons are connected properly. The main ribbon that connects the camera to the RPi only works in one orientation, check that the exposed leads are making contact with the contacts in the connectors.

The other ribbon is this one:
It can loosen or even completely pop off sometimes, and if that happens the camera will not work until it's connected properly.


So I've seen that suggestion on other posts, but my camera doesn't actually have one of those. It's an inland, which I think is a micro center brand. I've gotten a replacement thinking the first one is a dud, but maybe it's a software/hardware compatibility issue (they market it as a raspi cam).

Sorry, should've specified. At that address it shows "the webcam server is currently not running"

I'm kind of jealous, my MicroCenter never actually had any when I was trying to get one...

From what I understand, it's supposed to work without doing much. You definitely have the proper options enabled in the kernel (that's the supported: 1 output).

As long as detected returns 0 it's not being seen by the system, so OctoPrint and mjpg-streamer configuration isn't applicable. That usually means an issue at the hardware level...either the ribbon or the camera itself.

I'll try the original ribbon it came with when I get home. I installed the 610 mm so maybe it's broken somewhere along the length of it. I'll update asap

So no luck with another ribbon cable. What else could I try? I've already tested 2 camera modules and 3 ribbon cables. Could it be the camera port on the pi? Should I just get a certified RasPi camera? I'm not sure what else it could be hardware wise

So I took the led lights/whatever thingies off the sides and I have image! I'm guessing the power draw was too much

1 Like