Webcam stream not working but snapshot is

I'm Rather new to octoprint. running a raspberry pi 3, raspberry pi camera v2.

the snapshot comes up but the stream wont load. Capture

I ran sudo apt-get update and sudo apt-get upgrade
then i ran sudo-rapi-cofig and enabled the camera.

can anyone shed some light on how to get this to work?

Checkout the stream url (your image shows you where to find it).
Seems like the pi ip is missing in the url.

That's actually normal on the default config of OctoPi, it's simply a relative URL.

My bad. Sry @tsd66 :slight_smile:

Are you trying to access the web interface of OctoPrint from Windows? If so, try a different browser like Chrome.

Tried with chrome already, basically the Snapshot shows, but the stream is blank.

How about http://octopi.local:8080/?action=stream from your browser by itself?

Otherwise, cough up some logs.

I had a similar problem. I was able to get a stream working by installing octoprint anywhere and configuring the camera from their web-interface. It seems the install changed something that I couldn't find on my own. Maybe it will help you too.