Webcam Stream not working in Edge browser or OrcaSlicer

Camera model

ipCam (iOS)

What is the problem?

Stream doesn't work in Edge browser. Snapshot works. Stream works in OctoEverywhere, FireFox, Chrome, Opera and OctoApp on android.

EDIT Also NOT working in OrcaSlicer

I am using an ip webcam using ipCam app on iOS. I can access the mainpage which gives links to video and snapshot links. The addresses follow:

ip.address.on.ios:port - this is the main page
ip.address.on.ios:port/image.jpg - this gives a snapshot
ip.address.on.ios:port/video.mjpg - this provides video feed

I can access each link on both host and local machine (host - what octoprint is running on, local - another pc on local network). Octoprint works on both machines.

What did you already try to solve it?

Allowed ports on all devices involved, tried several different ports. Tried to find information on why Edge doesnt like the stream via octoprint, but has no problem opening it in its own tab.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36 Edg/
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 8
env.hardware.freq: 3400.0
env.hardware.ram: 8252194816
env.os.bits: 64 linux
env.os.platform: linux
env.python.pip: 23.3.1
env.python.version: 3.10.12
env.python.virtualenv: True unknown
octoprint.last_safe_mode.reason: unknown
octoprint.safe_mode: False
octoprint.version: 1.9.3
systeminfo.generated: 2023-12-04T23:20:57Z
systeminfo.generator: zipapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octorprint running on LinuxMint on MS Surface device. IP Cam thru app on iPhone. My default browser is Edge (please dont bully me). The obvious answer is "just use a different browser", but I do find this interaction curious. The only part of the equation which doesnt work is viewing the stream in octoprint in edge browser, everything else works.

I should add, that this originally started as a post about the ipCam stream not working fullstop(snapshot was working though), until i tried another browser while writing this up. I have seen some posts about they way octoprint and IE/Edge handle the stream. So I guess I'm just checking if theres any update or any work around, I havent been able to find one yet.

Have you tried in an inPrivate window?

1 Like

Upon further research (including inPrivate tab, Thanks for the suggestion @jneilliii) I have discovered an extension was blocking the webcams access. Disabling the extension has fixed the issue and the stream now works in Edge and OrcaSlicer.

As I was setting up firefox to use as default browser all of a sudden the stream stopped working.

Make sure your ad blockers aren't blocking your cam stream :slight_smile:

1 Like