Webcam Streamer

What is the problem? Need a webcam streamer (standalone)

What did you already try to solve it? Tried a dozen install options, none work

Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ...) Niether Octo-Pi nor Octo Print is installed. Trying to use the PiCam V1.2 on Ubuntu Xenial, (and/or) Raspbian Stretch (and/or) Buster. All I need is the streamer. The one Octo uses would be perfect

I think I may have figured out the problem. Not how to solve it, and this might not even be relevant...

The mjpg-streamer sends data to /usr/local/share/mjpg-streamer/www while the web server (nginx) serves pages at /var/www/html

Sneaking up on it...

A list of open ports told me...

mjpg_stre 2092    ubuntu    5u  IPv4  19382      0t0  TCP *:8080 (LISTEN)
mjpg_stre 2092    ubuntu    6u  IPv6  19383      0t0  TCP *:8080 (LISTEN)

Then visiting this web page
roscore.local:8080/stream_simple.html

Gave me this output...

501: Not Implemented!
no www-folder configured

Is there some sort of file in the two folders you mentioned above (with "www" in them)?

Yea, lots in both. This is the folder created by ROS, which has things both related and unrelated to the camera that I don't have (yet, it's on order). Some of this stuff is related to a control panel for moving the robot around

These files are in the folder created by the mjpg_streamer program...

When I type in the command to start the streamer program, I can see the little red led turn on on the camera, so SOMETHING is working. However, I also found this msg buried in the screen when I start the streamer...

 o: www-folder-path......: disabled
 o: HTTP TCP port........: 8080
 o: HTTP Listen Address..: (null)
 o: username:password....: disabled
 o: commands.............: enabled

In case yer wondering, yes, I 3D printed one (only one, the others are... different... Just testbeds) of the bots. It was a real pain doing all 70 of those individual tank treads (Ignore the C270 mounted on the front, the ROS software doesn't support it but I put it on anyway)

It sounds like you need to somehow turn on that www-folder-path in the config...?

I cheated, myself. I just bought the OSEPP tank kit. :laugh: Their individual treads are held in place by thin cylindrical pins which run through their width.

That's a great thought !

Any ideas how ???

I just now looked at that kit. It actually wasn't my intention to build any kind of toy or tank. I only built the tank cuz all the test beds I built weren't big enough to hold the batteries for all the stuff I was adding. The main one runs on a Jetson Nano running ROS with remote control, follow mode, blue tooth, fiducial recognition, facial recognition, line following, and I WAS planning to use SNIPS for the voice, but, right now I need the thing to see in order to figure out who it is that it needs to follow

The full size one is almost finished...

Yes. It's a toolbox. But, like I said, ALMOST finished. Not quite ready for the computer bits yet. It still needs a head :wink:

So, any ideas how to turn that www thingy on ? The documentation isn't the greatest. At first I thought that the 2 web servers were fighting, but, when I saw that they were using 2 different ports, I figured that was not the problem. Then I saw that error, and, well, that's where I got stuck. There's a bunch of ".so"'s but I didn't see a ".conf"

I really don't know that one. You might read through this thread though.

1 Like

I think you've hit on it !

According to the link, part of the startup command designates the location of the directory with the "-w" flag...

-w /var/www/mjpg_streamer"

Whereas I found mine at

/usr/local/share/mjpg_streamer/www/

and html was the only www folder I found here

/var/www/html

An obvious discrepancy. The thing is, I didn't put that folder there. The install must've done that (although I'm not ruling out a typo on my part)

I just tried typing the proper start command, and still no luck. The mjpg_streamer folder stayed right where it was, and it also didn't get created under var/www

I'm gonna see if I can move the folders around

The executable wants to be told if it needs a www folder or not; I assume that's the -w argument pair. Otherwise, it maybe just wants a single file to output like in some of those examples.

1 Like

Yea, I tried that first. It seems it's gonna be a tad more complicated than that. It seems I've created a new problem by putting things where they belong

ERROR: could not find input plugin
Perhaps you want to adjust the search path with:
# export LD_LIBRARY_PATH=/path/to/plugin/folder
dlopen: /usr/lib/input_uvc.so: cannot open shared object file: No such file or directory

Trying to figure that one out now. I found the file it's looking for, but, I think a better fix would be to edit the LD_LIBRARY_PATH if I can find it