Webcam will stream on octopiIP:8080 but not on /webcam/?action+stream

I have a Chinese webcam from amazon and when I plug it into my pi 4, I can stream from octopiIP:8080 but not the relative URL /webcam/?action=stream/

I've already tried switching USB ports but that yielded no results. I've also tried to edit /etc/haproxy/haproxy.cfg to change the webcam server from to /webcam/?action=stream but that also doesn't work.

octoprint (1).log (591.9 KB)

I have octoprint 0.17 from the preconfigured image on a pi4b.

did you try http://octopiIP:8080/?action=stream ?

I get a stream from octopi.local:8080 but not /webcam/?action=stream

Maybe my anwer wasn't the one you were looking for but please just use one thread.

just tested a fresh 0.17.0 image on a pi 4b

the setting works fine for me.

What did you modify on your image?

I just got a logitech c615. the chinese webcam doesnt work with a fresh image of octoprint but the c615 does.

And what did you change to make it work?

I bought a webcam off of the known working list and as advertised, it worked. I'm just going to return the Chinese webcam to amazon.

the Chinese webcam just started working with no changes.

Alrighty :slight_smile: