Webcam window stuck on "Webcam stream loading"


#1

What is the problem?

Can not get the webcam stream to work on either the local page or through the octopi.local/webcam/?action=stream address.

What did you already try to solve it?

First I tried editing the settings in the /boot/octopi.txt file according to guides found online (changing the camera default from auto to raspi, different raspi settings according to this: https://github.com/PrusaMK2Users/MK2_Tips_and_Tricks/wiki/Octoprint-Webcam-Setup). After that did not work I tried a different stream url in the local settings. After all that failed I wiped the pi sd card and started over fresh. Ran raspi-config and updated to make sure that was all up to date. After no changes I tried editing the settings same as above. Also, during this whole time the raspi cam led was on. Assuming that means it was getting power/is connected correctly. The whole time there was no change. It's probably something really simple to see once I post the logs. I appreciate your help.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Up to date version of both OctoPrint and OctoPi. Most up to date version of the Marlin firmware.

/boot/octopi.txt

## Windows users: To edit this file use Notepad++, VSCode, Atom or SublimeText.
### Do not use Notepad or WordPad.

### MacOSX users: If you use Textedit to edit this file make sure to use
### "plain text format" and "disable smart quotes" in "Textedit > Preferences"

### Configure which camera to use
#
# Available options are:
# - auto: tries first usb webcam, if that's not available tries raspi cam
# - usb: only tries usb webcam
# - raspi: only tries raspi cam
#
# Defaults to auto
#
camera="auto"

### Additional options to supply to MJPG Streamer for the USB camera
#
# See https://faq.octoprint.org/mjpg-streamer-config for available options
#
# Defaults to a resolution of 640x480 px and a framerate of 10 fps
#
#camera_usb_options="-r 640x480 -f 10"

### Additional webcam devices known to cause problems with -f
#
# Apparently there a some devices out there that with the current
# mjpg_streamer release do not support the -f parameter (for specifying
# the capturing framerate) and will just refuse to output an image if it
# is supplied.
#
# The webcam daemon will detect those devices by their USB Vendor and Product
# ID and remove the -f parameter from the options provided to mjpg_streamer.
#
# By default, this is done for the following devices:
#   Logitech C170 (046d:082b)
#   GEMBIRD (1908:2310)
#   Genius F100 (0458:708c)
#   Cubeternet GL-UPC822 UVC WebCam (1e4e:0102)
#
# Using the following option it is possible to add additional devices. If
# your webcam happens to show above symptoms, try determining your cam's
# vendor and product id via lsusb, activating the line below by removing # and
# adding it, e.g. for two broken cameras "aabb:ccdd" and "aabb:eeff"
#
#   additional_brokenfps_usb_devices=("aabb:ccdd" "aabb:eeff")
#
# If this fixes your problem, please report it back so we can include the device
# out of the box: https://github.com/guysoft/OctoPi/issues
#
#additional_brokenfps_usb_devices=()

### Additional options to supply to MJPG Streamer for the RasPi Cam
#
# See https://faq.octoprint.org/mjpg-streamer-config for available options
#
# Defaults to 10fps
#
camera_raspi_options="-x 1920 -y 1080 -fps 30 -quality 95 "

### Configuration of camera HTTP output
#
# Usually you should NOT need to change this at all! Only touch if you
# know what you are doing and what the parameters mean.
#
# Below settings are used in the mjpg-streamer call like this:
#
#   -o "output_http.so -w $camera_http_webroot $camera_http_options"
#
# Current working directory is the mjpg-streamer base directory.
#
#camera_http_webroot="./www-octopi"
#camera_http_options="-n"
pi@octopi:~ $ systemctl status webcamd
● webcamd.service - LSB: webcam daemon
   Loaded: loaded (/etc/init.d/webcamd; generated; vendor preset: enabled)
   Active: active (running) since Tue 2019-03-12 07:10:59 GMT; 2min 2s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 408 ExecStart=/etc/init.d/webcamd start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/webcamd.service
           ├─429 /bin/bash /root/bin/webcamd
           └─467 ./mjpg_streamer -o output_http.so -w ./www-octopi -n -i input_raspicam.so -x 1920 -y 1080 -fps 30 -quality 95 

Mar 12 07:11:00 octopi mjpg_streamer[467]: MJPG-streamer [467]: resolution........: 1920 x 1080
Mar 12 07:11:00 octopi mjpg_streamer[467]: MJPG-streamer [467]: camera parameters..............:
Mar 12 07:11:00 octopi mjpg_streamer[467]: MJPG-streamer [467]: www-folder-path......: ./www-octopi/
Mar 12 07:11:00 octopi mjpg_streamer[467]: MJPG-streamer [467]: HTTP TCP port........: 8080
Mar 12 07:11:00 octopi mjpg_streamer[467]: MJPG-streamer [467]: HTTP Listen Address..: (null)
Mar 12 07:11:00 octopi mjpg_streamer[467]: MJPG-streamer [467]: username:password....: disabled
Mar 12 07:11:00 octopi mjpg_streamer[467]: MJPG-streamer [467]: commands.............: disabled
Mar 12 07:11:00 octopi mjpg_streamer[467]: MJPG-streamer [467]: starting input plugin input_raspicam.so
Mar 12 07:11:00 octopi mjpg_streamer[467]: MJPG-streamer [467]: starting output plugin: output_http.so (ID: 00)
Mar 12 07:11:00 octopi mjpg_streamer[467]: MJPG-streamer [467]: Starting Camer
Starting up webcamDaemon...

--- Configuration: ----------------------------
camera:        auto
usb options:   -r 640x480 -f 10
raspi options: -x 1920 -y 1080 -fps 30 -quality 95
http options:  -w ./www-octopi -n
-----------------------------------------------

<13>Mar 12 07:11:00 pi: Starting Raspberry Pi camera
Running ./mjpg_streamer -o output_http.so -w ./www-octopi -n -i input_raspicam.so -x 1920 -y 1080 -fps 30 -quality 95
MJPG Streamer Version: git rev: ddb69b7b4f114f3c2ca01adf55712792ca8aed43
 i: fps.............: 30
 i: resolution........: 1920 x 1080
 i: camera parameters..............:

Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
 o: www-folder-path......: ./www-octopi/
 o: HTTP TCP port........: 8080
 o: HTTP Listen Address..: (null)
 o: username:password....: disabled
 o: commands.............: disabled
 i: Starting Camera
Encoder Buffer Size 81920

Gonna be out of pocket for 6-7 hours. I'll reply if you need more info asap. Thanks ahead of time.

Tyler


#2

If I could get some help with this it would be greatly appreciated. This afternoon I went through some more troubleshooting and testing. I tried multiple browsers (chrome, firefox, brave). In addition, I tried a couple different stream urls and tried multiple different camera settings to see if one of them would jolt something. No luck with any of them. Thank you ahead of time.

Tyler