Webcam won’t display. Help!

What is the problem?

I have an Ender 3 pro printer
I just got a raspberry pi 3 A+ and a raspberry pi camera
I’m powering the pi using the printer psu with a buck converter
However the camera is not displaying anything on the octoprint site.

What did you already try to solve it?

I tried rebooting the pi multiple times. Checked the ribbon cables few times. The camera turns on the pi detects the camera when I check via ssh terminal. But it’s not displaying anything. It says


Webcam stream loading…


I tried a different raspberry with the default
Raspbian os with the same camera everything worked

I tried the same pi with Raspbian os it also worked.
It’s just when I use octopi that the camera doesn’t work

Have you tried running in safe mode?

Yes. Still didn’t work

Did running in safe mode solve the problem?


What happens when you open this url in your browser http://octopi.local/webcam/?action=stream

Nothing really
It sends me to a page that take a long time to load. And then nothing

I tried sudo vcgencmd get_camera
And got
Supported=1 detected=1

However when I try
Raspistill -v -o test.jpg
I get this
I checked all the connections
The camera board lights up red

I tried everything here
Still nothing is displaying

I checked vcgencmd get_camera
Supported=1 detected=1

But When I try raspistill -v -o test.jpg
I get an error message (no data received from sensor.)

Please keep this in one thread :slight_smile:
I moved your second post back to this thread

1 Like

Did you update ? sudo apt-get … I had to do this on mine to get camera working. You can probably just raspi-config to do the update if you’re not familiar with commands in a terminal window