Webcamd service not activated

I have a Pi 4b, connected to a CR-10S. For quite a few months it has ran just fine, timelapses would spit out like clockwork, prints looking good. Then a few weeks ago the time lapses stop working, and after some investigation the webcamd service is always in "activating" state, not "active" state. And it seems to constantly restart every few minutes. I had this problem when i was doing the original build, and the;

sudo systemctl reset-failed webcamd.service

Cleared it right up, and as i said it ran for months. Only changes since are whatever plugins and such updated on the octopi, all latest. Needless to say this command has no effect now. Tried all the standard stuff, stop service start service, reset service. Is there a way to reinstall or repair the install of the webcamd service? I am I.T. savvy, but new to Pi world.

I do have 2 cameras, a Pi cam and a logitech C615 i believe it is. Again worked fine for months. I actually had this working with four camera, 2 additional Pi high quality cams, lens problem's got me to remove those 2, for now. I have a few other things attached, don't really think these are relevant, but just in case. I have some temp sensors, and fans, and relays triggering things in this build. I had Octoscreen running, but it started timing out too so removed it. Didn't have a whole lotta heart ache over that so the screen is unplugged now, however the plugins are still installed and running, and they do work, it just seems like it times out as well, however its timeout is hours.Not really concerned about fixing it at the moment, but these issues may be related, maybe not.

Another symptom is the control tab in octoprint does show both cameras, but seem to time out in about 30 seconds, and then just freeze. A refresh of the page and they both come back, for again 30 seconds or so.

I don't know how to run in safe mode, will be searching that next.

EDIT: I thought it might be relevant to mention that all devices are networked via hard wire, to a gigabit switch.

octoprint-systeminfo-20211018180324.zip (100.0 KB)

safe mode is a link, click on it and it tells you.
Or just choose the option from the system menue and restart octoPrint in safe mode.

How funny, overlooked it a hundred times. So i tried all the same stuff in safe mode, and no change.
I followed another post adjusting the time out period to 3 minutes, but i still get time out error when running

sudo systemctl start webcamd.service;

I get this

Job for webcamd.service failed because a timeout was exceeded.
See "systemctl status webcamd.service" and "journalctl -xe" for details.

After

systemctl status webcamd.service

Get

● webcamd.service - the OctoPi webcam daemon with the user specified config
Loaded: loaded (/etc/systemd/system/webcamd.service; enabled; vendor preset: enabled)
Drop-In: /etc/systemd/system/webcamd.service.d
└─startup-timeout.conf
Active: activating (start) since Wed 2021-10-20 18:09:04 MDT; 1min 39s ago
Cntrl PID: 1985 (webcamd)
Tasks: 15 (limit: 4915)
CGroup: /system.slice/webcamd.service
├─1985 /bin/bash /root/bin/webcamd
├─2034 ./mjpg_streamer -o output_http.so -w ./www-octopi -n -p 8084 -i input_uvc.so -r 1920x1080 -f 30 -d /dev/video0
├─2039 ./mjpg_streamer -o output_http.so -w ./www-octopi -n --listen 127.0.0.1 -i input_raspicam.so -x 3280 -y 2464 -fps 20
└─2068 sleep 120

Oct 20 18:09:05 octopi mjpg_streamer[2039]: MJPG-streamer [2039]: resolution........: 3280 x 2464
Oct 20 18:09:05 octopi mjpg_streamer[2039]: MJPG-streamer [2039]: camera parameters..............:
Oct 20 18:09:05 octopi mjpg_streamer[2039]: MJPG-streamer [2039]: www-folder-path......: ./www-octopi/
Oct 20 18:09:05 octopi mjpg_streamer[2039]: MJPG-streamer [2039]: HTTP TCP port........: 8080
Oct 20 18:09:05 octopi mjpg_streamer[2039]: MJPG-streamer [2039]: HTTP Listen Address..: 127.0.0.1
Oct 20 18:09:05 octopi mjpg_streamer[2039]: MJPG-streamer [2039]: username:password....: disabled
Oct 20 18:09:05 octopi mjpg_streamer[2039]: MJPG-streamer [2039]: commands.............: disabled
Oct 20 18:09:05 octopi mjpg_streamer[2039]: MJPG-streamer [2039]: starting input plugin input_raspicam.so
Oct 20 18:09:05 octopi mjpg_streamer[2039]: MJPG-streamer [2039]: starting output plugin: output_http.so (ID: 00)
Oct 20 18:09:05 octopi mjpg_streamer[2039]: MJPG-streamer [2039]: Starting Camera

The service status gives you quite a brief overview that is not particularly helpful, doesn't it..

However, it does seem to be loaded, and there's no error there.

A more detailed log file is available in /var/log/webcamd.log, you can open that file and see if it is complaining about anything, and if you can't see any problems you can fix obviously, upload it here and we will take a look

Yea, i use the Journal -xe and it isn't very useful either, to me anyway. I'll have a look at your suggestion when i get home.

Yea you can tell the drop in for the timeout period is working as well, but its just always activating, not active. The active status text is also green when it is active, and mine is not.

I did upload the bundle package in my original post, but i don't know if that log is included.