Webcamd stopped working

Camera model Pi HQ

What is the problem? Webcamd isn't streaming

What did you already try to solve it? Restart service, reboot, re-seat camera cable

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)


Starting up webcamDaemon...

--- Configuration: ----------------------------
cfg_file:      /boot/octopi.txt
camera:        raspi
usb options:   -r 640x480 -f 10
raspi options: -fps 10 -awb tungsten -sh 50 -ex auto -quality 100 -x 2592 -y 1944 -rot 180
http options:  -w ./www-octopi -n --listen

Explicitly USB device:

Found video devices:
Scan again in two minutes

sudo systemctl status webcamd.service

● webcamd.service - the OctoPi webcam daemon with the user specified config
   Loaded: loaded (/etc/systemd/system/webcamd.service; enabled; vendor preset: enabled)
   Active: activating (start) since Mon 2023-02-06 09:42:06 GMT; 43s ago
Cntrl PID: 1106 (webcamd)
    Tasks: 2 (limit: 3597)
   CGroup: /system.slice/webcamd.service
           β”œβ”€1106 /bin/bash /root/bin/webcamd
           └─1117 sleep 120

Feb 06 09:42:06 octopi systemd[1]: Starting the OctoPi webcam daemon with the user specified config...

Additional information about your setup (OctoPrint version, OctoPi version, ...)

RasPi 4B, latest stable release of octopi/octoprint, fully updated via apt

Camera confirmed to be working via both raspistill and raspivid.

Configuration in octopi.txt:

camera_raspi_options="-fps 10 -awb tungsten -sh 50 -ex auto -quality 100 -x 2592 -y 1944 -rot 180"

This was working previously, I've made no change to the camera configuration in the meantime.

http://octopi.local/webcam/?action=stream reports "The webcam server is currently not running"

System bundle attached (177.9 KB)

This is getting even weirder. I tried octopi 1.0-RC3 and the camera was working again.

...Right up until I edited octopi.txt.

Even with camera_raspi_options commented out it breaks when I specify camera="raspi" but works for camera="auto"

Did you choose 32 or 64 bit version of OctoPi 1.0.0? I suspect I know why the 0.18 stopped working for RPi cams after it was fully updated with apt, but I think this should be fixed with 1.0

I tried both 32 and 64 bit, same problem with missing as reported here:

I've come to the same conclusion that something must have broken following an apt update.

Re-flashing with the latest stable has fixed it, so I'm avoiding updates for the time being.