Webcame works everywhere execpt OctoPrint

Camera Model : Logitech C525

Whats is the problem?

Have installed mjpeg-streamer (a couple of of ways via various tutorials), and the camera works fine. Zero issues getting a stream.

I then put the Stream URL into the OctoPrint Settings Stream URL, and try to test the camera, and get nothing. But the SnapShot works fine, I get an image

Saving the settings, I then go to the control tab I get a black window with a "Stream not loaded message" This text contains a link to the currently configured stream, following that link takes me to a perfectly working stream.

What did you already try to solve it?

Install mjpeg-streamer a couple of differnt ways
Read every post on this forum that even hinted like it might have the answer, tried a few things from various posts but no change.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

I have looked at various logs, and nothing shows anything interesting that I can see. I would rate myself as intermediate experience using Linux. Can extract logs if someone is looking for sepcific detail

Additional information about your setup (OctoPrint version, OctoPi version, ...)

OctoPrint 1.3.12

I am not using the Octopi image, as I use my pi for other things as well (mostly MQTT / NodeRed), so I installed it manually using the install guide. OctoPrint seems to be working just fine, its a couple of hours into a print as I type this.

Which stream url are you using? Maybe there is a typo or something

But then the link that is impeded in the control tab window wouldn't work. Below is a screen shot. That link in blue works.

image

what about http://192.168.1.28:8081/?action=stream

That worked. I have tried so many variations you begin to go in circles.

Thank you very much.