Webcams not working

#1

EDIT: These worked a few days ago but suddenly didnt work anymore. im not sure whats happened and idk how to diagnose the problem.

Webcams are not working for some reason. I have the raspberry pi 3 B+. I bought a new one thinking my raspberry pi must be messed up but it doesn't work on it either. I have linked my two cameras at the bottom.

I tried several different ribbon cables. Nothing gets the camera to work. Here are the logs

I wasn't using a usb camera but just in case i added camera_usb_options="-r 640x480 -f 10 -y" to the octopi.txt file. But it didnt work so i took off the "-y". Also, I restart the raspberry pi every time to change the cameras or when I changed the camera. I am running the latest version of octopi and have updated all plugins and libraries.

Here are the two cameras I bought . The system isnt letting me link these two :confused:
Camera1: Day-Night V2 for Raspberry Pi Camera, Arducam All-Day Image All-Model Support, IR LED for Low Light and Night Vision, M12 Lens Interchangeable, IR Filter Auto-Switch Programmable, OV5647 5MP 1080P
and
Camera2: Arducam 5 Megapixels 1080p Sensor OV5647 Mini Camera Video Module for Raspberry Pi Model A/B/B+, Pi 2 and Raspberry Pi 3,3B+

#2

Try reading the comments for the second one to see what others did to get theirs to work.

#3

I forgot to mention that that they worked a few days ago but suddently didnt work any more.

#4

Something has changed. Perhaps the camera died (see the comments). For example...

Bought one. it fell apart after 2 days. Bought a second one, and the video has degraded after only 3 days. It was fine, now it looks like the attached picture. I bought this to run via OctoPi so I could monitor my pi from anywhere, but I can't keep buying a new camera every 4 days :frowning:

#5

but both camera tho? the ir camera is fairly new and was never used. it worked before but doesnt now. I only used the Ir camera when i got it to see how it looked and never used ti again

#6

By your own admission, you have been swapping stuff around and a bit of static electricity could have damaged both. Another possibility (and I know this from personal experience) is that the ribbon cable is upside down or not seated well. I would have preferred a big green stripe on the ribbon cable and an obvious mark on the connector that indicated "green side up" :smiley:

1 Like
#7

ok so i got a new raspberry pi, new camera (came with new ribbon cables). iim having the same issue. im convinced it may be somethign wrong with my octopi. what can i fix

#8

Hopefully, you have a spare micro SD card. If you do, I'd suggest downloading and creating a new OctoPi image and make as few changes as possible to get it on your network. If I remember right, you also need to enable camera support but I'm pretty sure that is documented here somewhere.

If you can take pictures of the ribbon cable attached to the camera and attached to the Pi, that might help us figure out if the ribbon cable is installed correctly.

Here's a link with pictures that might be useful, https://thepihut.com/blogs/raspberry-pi-tutorials/16021420-how-to-install-use-the-raspberry-pi-camera. That's all I can think of now.

#9

If it's helpful, the photos in my Pi NoIR tutorial are useful for orienting each end of the ribbon cable correctly in each of the connectors.