Website is unresponsive while printing and using a FullHD Camera

What is the problem?

Since I switched to a FullHD camera (Logitech C920), i noticed some major issues with the Webinterface. When I start printing, the Webinterface becomes massivly unresponsive. For example: Webcam is lagging / freezing, website reacts on button clicks after 10 seconds. So all in all, while printing the Webinterface isn't usable. If I'm going directly to the webcam stream via webcam/?action=stream, the stream is running smoothly without problems. I tried a fresh Octoprint installation withoout any plugins, but the problem persists. If I'm not printing, everything is responding fine. Maybe an USB Overload Issue ? The logs doen't provide any informations relating to the issue.

Have you tried running in safe mode?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (34.9 KB)

Did running in safe mode solve the problem?


Additional information about your setup

Version 1.8.7 running on docker on a Pi 4B 4GB

Hello @CreatorSimon !

There was a request for the systeminfo bundle?

Where is it gone?

Please share actual version numbers. "Latest" can be quite old in a short time.

Also please share the OctoPrint version.

Hello @Ewald_Ikemann !
Thanks for the reply, I have added the systeminfo_bundle to the original post.
The Server version is Version 1.8.7

Kind regards

Further Information:
After further investigation, it should be a Problem from the embedded webcam stream. Because when I'm switching to an other main tab so that the webcam isn't showing, everything is running fine and all buttons are responsive.

The camera feed maybe is overloading your wireless network in some way. A single feed from OP can produce ~15Mbps it may not sound like much but if you also have a lot of IOT items connected to your access point or you are also running several other streams at the same time, that can get to be a lot. If you are not seeing performance issues with your prints and when you are not viewing the stream, it might be more of a network or client performance issue than a Pi performance issue.

Thanks for you reply! I already thougt about it, but I'm using Ethernet with 1 GBit in my Local Lan, so I dont think that this should be the problem :thinking:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.