Websocket failed to connect and extremely glitchy UI

What is the problem?

I recently installed OctoPi 32-bit on my Raspberry Pi 400 for my Prusa MK3S+ printer. However, the UI is very unresponsive and I was able to track it down to the web socket not connecting. Any ideas on how to fix this?

What did you already try to solve it?

I uninstalled all my plugins and looked through the log files. I couldn't find any errors in the logs. I also tried enabling CORS in the API settings.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog... no bundle, no support, unless the reason you couldn't retrieve the bundle is your network issues

octoprint-systeminfo-20231026132612.zip (1.1 MB)

Additional information about your setup

Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ... as much data as possible

Raspberry Pi 400 with Prusa MK3S+ printer with Logitech 720p Webcam

Never mind. It was a computer issue.

1 Like