WebUI within the RasPi unbearably laggy and HOT


#1

What is the problem?
I have a 7" touchscreen connected to the Raspberry and I've wanted to use it as a printing console.

What did you already try to solve it?
I've set up "Desktop logged in" option in "raspi-config", downloaded Chromium for it, and get in 0.0.0.0, but the screen becomes almost unresponsive, acting completely random on moving the screen up or down (With, and without TuchUI), and the processor literally burned my finger...

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)


#2

Run top. But to me it sounds like your Pi is simply not up for the task of running a print server, driving a 3d printer AND also running a full fledged modern web browser with a UI optimized to shift as much work from the server away as possible (read: to be accessed from a different machine).


#3

I'm sorry, but I'm REALLY new with Linux and Raspberry... What do you mean with "top"? I simply type "top" in the console?
I've tried that because I've seen it in some Thingiverse projects, YouTube videos... And it was working fine.
Also, it wasn't printing when I've tried it, due to reboots and so.
Maybe I've skipped some step in the process?
BTW, it's a Raspberry Pi 3 B, the newest ones, if I'm not wrong...


#4

Yes. top is a tool that shows you what processes on your system are using how much of the system resources. My guess is you'll see Chromium sitting at the very top of top, with something way past 100% CPU utilization. Or it might be something else that's causing everything to lag. Hard to guess, better to just run top through PuTTy (SSH client) and just make a screenshot and put it here :slight_smile:


#5

Ok, I'll do it maybe in an hour, but I'm pretty sure is because Chromium... I can see it in the processor usage percent with 100% usage in the lower right corner of the desktop every time I open it, and when I close it, it goes back to maybe 2% or something like that, lol.
If so, maybe I could try with another browser? Which is the lightest browser for Raspberry, able to run all the plugins and applets that OctoPrint uses?

Edit: BTW, how could I uninstall programs? Iv'e found this SUDO PURGE, but it doesn't work... (I don't have Raspie with me now)


#6

Sorry, I can't answer this. And personally I do not recommend running the OctoPrint server and the OctoPrint web interface on the same Raspberry Pi for exactly these kinds of reasons, even though a lot of people seem to have no issues.


#7

Oh, well... So sad to hear that. It looks too beautiful to not try it...
Anyways, thank you very much for your help. I will try to resell the screen and buy a cheap android tablet then. Hahaha


#8

Maybe someone with this kind of setup will still chime in and have some hints for you. Sorry to not have a solution for this up my sleeve :wink:


#9

Actually my decision on doing it was fired by this guy:


But of course, there's some commands that he does that i didn't want to try, to not mess it more up, due that I don't really understand what he is doing exactly. This is why I've made it in the easy way. raspi-config and done.
Maybe you can understand what he is doing with all these commands.

Danke Schön fur Ihre Hilfe! You are making an amazing work