Wecam worked then randomly stopped?

What is the problem?

I was using an RPi camera v2.1 connected to my RPi 3B. It worked for a while then one day stopped working. I don't know if this correlated with some time I installed a plugin or not, as I had only installed OctoPrint a week ago and had been trying out various plugins etc.

What did you already try to solve it?

  • tested cam on a different Pi (switched SD card from my Pi3B to the Pi2 so it was running same software)
  • tested different cables
  • bought a NEW camera 3.0, assuming it was a faulty camera
  • run vcgencmd get_camera, which returns supported=1 detected=0, libcamera interfaces=0
  • I have not yet re-installed OctoPrint, it doesn't seem required as OctoPrint doesn't run the camera server. However logically it would seem the next step given the above

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No - so I guess it's not an issue with other plugins causing a problem

Systeminfo Bundle

camerastack-usb.zip (2.1 KB)

Additional information about your setup

Octoprint 1.9.3
Octopi Build 2023.10.09.154319 with "camera-streamer", based on OctoPi 1.0.0, running on Raspberry Pi 3 Model B Rev 1.2
Printer: Prusa MK3S
Browser / OS: Chrome / Win 11

Update: I re-imaged OctoPi and the camera started working again.

Having spent hours reading through various instructions about troubleshooting the RPi camera (including everything on this forum) - of course the basics I did such as checking camera was enabled and I2C interface was enabled - I have zero clue why I was unable to get it working.

Obvs not a problem with OctoPrint. Anyway - solved.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.