Weird printing problem

I am printing some medium size face shields. I am using a Rostock Max v2 with an HE280 hot end, Raspberry Pi 2, and Octoprint 1.4.0. I use Cura as my slicer, with the SeeMeCNC recommended profiles. When I first start the system I get a very good print. If I use the print button in Octoprint to print a second shield, it starts cleanly and then the print always fails about half-way through.

If I shut down the printer, the Pi, and Octoprint and restart them, I get another great print. Any ideas on fixing this?

Have you repeated all this in Safe Mode? It's possible that one of your third-party plugins is either causing some sort of JavaScript or memory leak problem.

Tried Safe Mode, same result.

If this were me, I would do a remote session to the Pi after startup and after OctoPrint is seen in the web interface. In this session, I'd do an htop and write down the memory usage.

I'd then finish the print and check the memory usage after it had finished. If the memory usage has changed significantly from before (especially if it's now using swap memory) then there's a problem of some kind.

1 Like

Logs of a failed print might help :slight_smile:

The problem destroyed my hot end. I only have one spare, so I am running MatterControl directly until I can repair my damaged one. I'd like to order a third hot end from SeeMeCNC, but it is out of stock. Once I can risk it, I'll run the Cura/Octoprint setup again and get the logs.


May I ask how? Did it crash into the bed or something?

Smashed into the bed repeatedly.