Weird wireless issue

My octoprint is connected wireless (WPA2). I can connect to it over my wireless laptop and use the web ui. After a while of inactivity I lose connectivity. I cannot ping the wireless interface. Bizare thing is my firewall/router which hands out the dhcp address can ping the interface but none of my other devices (wired and wireless) can ping it. I log into the raspberry pi console via hdmi and I can ping the my firewall/router. I reboot my raspberry pi and I get connectivity back until a little inactivity and I lose connectivity.
Can someone point me how to fix this ?

Is your power supply sufficient?
If you can try another one - maybe it's unstable.

Is your wifi country set?
If not or you're not sure just set it again. If you're in desktop mode: menu options -> Preferences -> Raspberry PI Configuration -> Localisation -> Set WiFi Country

In console mode run

sudo raspi-config

go to localisation options -> change wifi country.

If it still doesn't work try

sudo rpi-update

in console

I hope that helps :slight_smile:

power supply is 5v 3A, I had set the country in the config file but I did it again via raspi-config. Just ran the rpi-update. Let see how this goes, thanks!

I gave up and ran cat5 cable

I think the wireless losing connectivity might be related to power management on the wireless interface. I ran below;

sudo iwconfig wlan0
I get
Power Management: On

I can turn off via
sudo iwconfig wlan power off

I will monitor it and see if wireless stays on.

well that did not help so never mind.

Hey I found something new


iw wlan0 set power_save off

and test with

iw wlan0 get power_save

if it worked.

This setting will be resetted after reboot, but if it works I found a way to make it permanent.

1 Like

I will test it tomorrow, thanks.

Gets reset after a reboot.

added this line in rc.local
/sbin/iwconfig wlan0 power off

after reboot, iw wlan0 get power_save shows "off".

Is this the right way to make is permanent ?

well never mind, lost connectivity again even after power save was off. Had to go to the console and ping something on the network then was able to ping the RP3 to get connectivity back.

I wonder if it's possible that this is just bad hardware. If you have another Pi you might try it.

I have another pi running librelec. i will test to see how it does.

The permanent way I found was this

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
wireless-power off


Another thing that came through my ming - do you have a static channel selected on your router/access point or is it on auto channel?
If it's on auto channel you could try a static one. Maybe the channel changes and that's the root of the problem.

1 Like

I lost connectivity so I was going to look at my access point, the access point reported that a fimware update was available. Some bug fixes were in the firmware. I updated the firmware and rebooted and I got connectivity back. So lets see if this sticks.

I had been having this exact issue with my pi, and it would happen while idle or while I was printing, so I would be unable to connect to it while printing. I had recently turned a spare 24v PSU into a pi PSU using a buck convert. It turns out my issue the whole time was this PSU I was using, when switching back to my old power brick that doesn't supply enough amps the wireless hasn't had an issue since, and its been about 3 weeks now.
My dream of using one PSU to power my 3 pi's is dead =/

1 Like

after updating the firmware on my asus access point I think I have this resolved. Many thanks for the ideas and suggestions.

1 Like

I'll 2nd this. While using wifi for the pi I had numerous disconnects with iPad clients. After awhile, the iPads would just slow down and then finally stop responding. I connected the pi up with ethernet and now it blazes all over the house. If it's possible, it's probably best to hardwire the pi.