What happened to "Select Tool"

What is the problem?

I just upgraded to 1.5.0 and lost the control to "select tool". On the Control tab under Tool there used to be a "select tool" dropdown menu. It is necessary to select the tool before sending extrusion commands for priming the extruder either via the extrude buttons on the same tab or via a gcode command such as G1 E100 F5000. Attempting to prime the extruder without selecting the tool puts my machines into an error state which causes the board to reboot.

What did you already try to solve it?

I have a work-around to accomplish this via the Duet mainboard but would like this functionality restored to Octoprint.

Have you tried running in safe mode and if so did it solve the issue?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

From terminal:

Send: G1 E5 F300
Recv: ok
Recv: Error: Attempting to extrude with no tool selected.
Send: M82
Changing monitoring state from "Operational" to "Error: Attempting to extrude with no tool selected."
Send: M112
Send: N3 M11234
Send: N4 M104 T0 S0
Send: N5 M140 S0*96
Changing monitoring state from "Error: Attempting to extrude with no tool selected." to "Offline (Error: Attempting to extrude with no tool selected.)"
Connection closed, closing down monitor

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.5.0 , RepRap firmware for Duet 2

I think that is hidden when there is only one tool, is this the case for your printer? If not we may be able to get a custom control for you - or it is a bug.

It was not hidden prior to update. As most printers only have one tool and there are extrude and retract buttons that don't work without selection of a tool, it seems like a bug. The error may be a feature of the Duet board and its' firmware though and may not present with other firmware.

Sorry, that was not clear - it is a new thing, that the UI is improved now as select tool is redundant on single tool extruders.
What firmware are you using? Since (I don't think) this is not a problem on Marlin Firmware, at least for me. If you could enable serial log, reconnect to printer and then upload it that would be good.

It's here on the control tab:


Yeah, but only when you have more than one extruder.

1 Like

The Duet 2 runs RepRap firmware. I'll get a serial log. Thanks for your help.

Sure! It would not make sense with only one...

Thanks Ewald--that is where I'm used to finding it. It has disappeared after updating to Octoprint 1.5.0.

I assume you checked the settings for the number of extruders?
Also try in safe mode

@Ewald_Ikemann It is in the release notes, I was involved in the conversation about removing it... Think this might have been overlooked that some FW requires it even for single tool.

I'll look and see if (a) a single file plugin to fix this for you can be made, or something to put in the custom controls are.

1 Like

Thanks Charlie. Here is the serial log:

2020-12-01 13:20:04,976 - Changing monitoring state from "Offline" to "Detecting serial connection"
2020-12-01 13:20:05,185 - Performing autodetection with 1 port/baudrate candidates: /dev/ttyACM0@115200
2020-12-01 13:20:05,186 - Trying port /dev/ttyACM0, baudrate 115200
2020-12-01 13:20:05,190 - Connecting to port /dev/ttyACM0, baudrate 115200
2020-12-01 13:20:05,209 - Handshake attempt #1 with timeout 2.0s
2020-12-01 13:20:05,216 - Connected to: Serial<id=0x6de840d0, open=True>(port='/dev/ttyACM0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=2.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
2020-12-01 13:20:05,218 - Send: N0 M110 N0125
2020-12-01 13:20:05,220 - Recv: Bad command: etwork running,s
2020-12-01 13:20:05,224 - Recv: ok
2020-12-01 13:20:05,228 - Changing monitoring state from "Detecting serial connection" to "Operational"
2020-12-01 13:20:05,237 - Send: N0 M110 N0
2020-12-01 13:20:05,318 - Recv: ok
2020-12-01 13:20:05,322 - Send: N1 M11539
2020-12-01 13:20:05,323 - Recv: ok
2020-12-01 13:20:05,327 - Send: N2 M21
2020-12-01 13:20:05,328 - Recv: FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.03 ELECTRONICS: Duet Ethernet 1.02 or later FIRMWARE_DATE: 2019-06-13b2
2020-12-01 13:20:05,360 - Recv: ok
2020-12-01 13:20:05,396 - Recv: SDHC card mounted in slot 0, capacity 3.98Gb
2020-12-01 13:20:05,430 - Recv: ok
2020-12-01 13:20:10,629 - Send: M105
2020-12-01 13:20:10,938 - Recv: ok B:64.9 /65.0 B1:65.0 /65.0
2020-12-01 13:25:43,077 - Send: M105
2020-12-01 13:25:43,102 - Recv: ok B:64.9 /65.0 B1:65.0 /65.0

Try going to the printer profile & increasing the number of extruders. I need to check what side effects it has, but it will re-show the button for you. If it breaks other things, then we will go down the single file plugin (temp fix) and get it fixed for the next release, with RRF.


I think I have a solution. I just added a "T0" under "Settings> Gcode Scripts> After connection to printer is established". Problem solved. Thanks again!