What happens in version 1.5

I´ve just upload to the version 1.5 and my problems starts. Everytime i want to use octoprint, load the site and its dont open. Whats wrong? The Raspbian is the same which works with the last version of octoprint.
Really, i dont like this new version. Its bad.
I dont understand what changes in this new version changes the way of network works and i think this must be invisible to the users and dont bother the use of octoprint with 3d printers.
i will return to the last version wich works fine with my rasp pi 4.

Try the IP address to rule out name resolution issues, we are currently trying to figure out an issue reported after the release of 1.5.0.

It was tested on 1334 instances over the course of almost a month and saw 3.4 years of collective printing before it was even released. There is no general crippling issue with it. In fact, no issues at all reported during the RC phase were left unfixed when I pushed it out. I cannot do much else than seek feedback, it is up to the community to help identify issues in release candidates before stable releases. You are free to roll back, you are free to not use it, but saying something is bad just because you ran into an issue with it that's currently being looked into and wasn't reported before release or during development is decidedly uncalled for.

I'm frankly fed up with getting told my work sucks by random people on every single release, usually due to issues they either caused themselves, or due to problems that I would happily solve if they collaborated with me on it. I'm one person pretty much singlehandedly running this project, giving it away for free and hoping I make enough in donations to be able to continue to do that. It is open source, everyone can contribute time, testing, logs, code, documentation, support, money to help make it better. Only a fraction of users do. You are free to use OctoPrint, you are free to not use OctoPrint. But you are not free to complain unless you are also prepared to roll up your sleeves and put in your own time and elbow grease to help improve it for everyone else. It's as simple as that.


Hi Gina,

Totally agree with you, a single sentence cannot describe the amazing job you have done with Octoprint.

To move on with my personal case, 1.5.0 is perfect for me, except this issue.
After the test this morning, I switched off for a couple of hours, and then on again, and guess what the issue is still there!

It's no serious issue for me, I'll continue to investigate.

My old engineer gut feeling tells me there is a border effect between this release, my network config, and may be even my FAI,the fact things related to name resolution have been changed, and I have no doubt we'll find the solution over time, by accumulating experience together.

I will pursue my side, and as soon as I have new facts, I will let you know!

Many thanks again


Im just say which this version upgrade sucks my normal way to connect. I dont say what this program octoprint is bad. Dont pur wirds in my mouth or my text. I think you understand wring my colocation. Sorry if you feel this way. Not my intention, my only intetion is related with no connection of octoprint in this new version.


And isay mire, your work with this is amazing!! I really appreciate it

But in this last upgrade, im experience a lot of errors during the connection, during the print, lost works in printer, so , because that i wrote that.

Sorry again

We can see that english is probably not your native language, and that is fine. It is not my native language either. But for future reference, telling someone that something they worked on for months "sucks" is a rather unfriendly and frankly somewhat rude statement. Instead you could have said "the update does not work, but the previous version works very well". Just avoid the word "suck" in reports.

Update: Ah, hmm... You did not use the word "suck". I am sorry I put that word into your mouth. Even so, the message I was trying to convey is that you can say "hey, the update does not work for me" instead of "Its bad". Chances are someone will be able to help.

1 Like

In their defense, they did, that was paraphrasing a lot of stuff from the past few days including this one on my part.

1 Like

Sorry for all that
Really, im a brazilian.
Excuse me for the wrong comment in the wrong way. I really dont like this. I ve tried to comment what ive been pass, not criticized.


Im really embarrassed with this situation, sorry sorry


Don't be. Please feel welcome in this community. Sometimes something someone says hits a nerve, and it is unhealthy to keep feelings bottled up.

We all sometimes need to take a step back and consider our words carefully, like I should have. Don't worry about it too much.

Now on to the issue at hand. It would be helpful if you can read this thread and see if there is anything there that you can try with 1.5.0 and then report back in that thread.


Okay ill made that and tell you after


@Igor_Chaves Apology accepted, and sorry in turn for my own explosion. I'm under a ton of pressure with this project, even more so after every stable release, and sometimes it just piles up too much. It made me not weigh your comment against the obvious language barrier, and read it in the worst possible way, prompting my comment. I'm sorry for directing that at you (though I stand by the comment in general for everyone else out there who does what I pointed out as unacceptable). Let me also extend a welcome to you, and underline the recommendation to check out the mentioned thread.


Thank you so much. At night i ll try and ll let you know about.

Thanks again

Gina, good afternoon!!

I’ve applied this:


and any kind of connection, as with ip or name now runs. I think what my raspberry didn’t have the dns configurated, and now, it is


Look that

(Attachment IMG_0952.MOV is missing)

(Attachment IMG_0951.MOV is missing)

I have upgraded to 1.5.0 and now cannot connect to anything using the IP addresses. Does the new 1.5.1 solve this. none of my Wifi settings seem to stick but if I plug it in via LAN it works fine connecting via that ip address

update: I have managed to solve one of my octoprint instances by installing the desktop gui then entering the wifi stuff via that way and it seems to have stuck. the others are hard mounted and will take a bit of work to get access to. currently running 1.5.1 on the working one.

I have no clue whats happening with my Ender 3 and Maker Select v2
After updating to 1.5.0 all these weird things started, artifacts, halt messages, random beeping.
Ive updated both to 1.5.1 and im still getting all these oddities. Anyone else seeing these?


Ender seems to have cleared up removing octolapse all together, running a test print now to test it

Maker Select may actually be having issues internally....random coincidence I suppose

@KellytehGeek Please don't hijack unrelated threads with your own problems. If you need help, open a new topic.