What is with all the "Recv: busy:processing" messages?


#1

What is the problem?
With OctoPrint 1.3.10 I'm getting
Recv: busy:processing
Printer seems to support the busy protocol, adjusting timeouts and setting busy interval accordingly

and then a lot of
Recv: busy:processing

What did you already try to solve it?
Nothing yet, printer is still printing

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
OctoPi 0.14, OctoPrint 1.3.10, LulzBot TAZ 6, Marlin 1.1.9.28


#2

Those messages come from your firmware. It's the firmware telling any connected host that it's currently really busy with something (e.g. a blocking heatup, homing or other long running command) and therefore cannot receive and process any new commands for the time being.


#3

Any chance of getting OctoPrint to suppress those messages? A check box like "Suppress temperature"?


#4

Terminal filters are configurable via Settings > Terminal filters, so just add a filter there and it will pop up as a new checkbox.

Recv: busy:processing should work as RegExp.