What Version of Python should Octopi 0.18.0 Have?

What is the problem?

I thought that the Octopi 0.18.0 image came with Python 3.6. When I check the version it is 2.7.16.
How can I upgrade to 3.6?

What did you already try to solve it?

I downloaded the "Latest Stable Build" today from Octoprint.org.
I used BalenaEtcher to extract the image to my uSD card that used to have a working 0.17.0 image on it.
I configures the octopi-wpa-supplicant.txt file for my network.
I booted the Raspberry Pi 4 then SSH'd to it to configure some of the settings with sudo raspi-config
When I logged into the the new image and queried the Python version, I see:

Access OctoPrint from a web browser on your network by navigating to any of:


https is also available, with a self-signed certificate.
This image comes without a desktop environment installed because it's not 
required for running OctoPrint. If you want a desktop environment you can 
install it via

    sudo /home/pi/scripts/install-desktop
OctoPrint version : 1.5.2
OctoPi version    : 0.18.0

pi@octo2pi:~ $ python -V
Python 2.7.16
pi@octo2pi:~ $

I searched on the web and tried to upgrade, but I see a message that Python 3 is already installed.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

I have not performed the initial Web Setup.

Additional information about your setup

My host Machine is a MacBook Pro, I'm running 11.1, Gig Sur, my balenaEtcher is V1.5.71.

You're looking at the default system python version. You need to look inside the virtual env (~/oprint/bin/python -V), and also listed on the OctoPrint home page in the bottom left hand corner of the footer.

1 Like

Thanks Jnei,
I am not an expert. I ran into this problem when I tried to install the Google Drive Backup Plugin. Do you have any suggestions?

Use ~/oprint/bin/python for anything OctoPrint related.

Or just source ~/oprint/bin/activate

I tried your suggestion and:

pi@octo2pi:~ $ source ~/oprint/bin/active
-bash: /home/pi/oprint/bin/active: No such file or directory

How would I edit the plugin installation?


Spot the difference :wink:

Thanks. That worked.

How can I add that command so that it takes effect on boot up?