Where to place xinput command for startup

What is the problem?

Where do I place
@xinput set-prop TSTP MTouch Coordinate Transformation Matrix -1 0 1 0 -1 1 0 0 1
for startup? I'm using TouchUI - Interface, and the 3 usual autostarts only works with booting to the X-Windows (wich the TouchUI-Interface does not seem to start.

What did you already try to solve it?

--working fine when I boot to X, but not to touchUI

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

If your /boot/config.txt has an entry near the bottom which begins with dtoverlay then look into configuring your TFT screen there. The arguments should support rotating either/both the display itself and the touchscreen portion.

Refer to the conversation I had with Ada (of Adafruit) regarding this same topic. Most vendors assume you'll be in the x windows system and never even imagine that you might need this to work at the terminal level.

That's what I call a quick response... :slightly_smiling_face:

Well the above xiput-line is just an example. It's not about only rotating (seems to be richt already) but calibrating the whole geekcreit TFT35 via the matrix I have still to calculate. Where and how to calibrate this?
Right now I can move the cursor to the corners I tap on, but no chance with someting in die middle...

As talked about in that github issue, I've used evtest in the past. This may be the one used for adjusting the terminal-only version of adjustments.

The xinput begins with the letter x and is for the Desktop/x windows system only. So it's not going to help you here.

It may be worthwhile reading the Adafruit tutorial for one of theirs. Continue past that page where it talks about calibration.

Ok, the dtoverlay can change the orientation and I can use the waveshare drivers.
On the Adafruit Tutorial I gut stuck on
`sudo apt-get install evtest tslib libts-bin resulting in "tslib not found".
evtest command not found
after gitting & compiling tslib I get "shared object libts.so.0 not found".

tslib is the crucial part for calibration without x, right? Or is there a different approach?

In a strange way.
-First I switched back to X via LCD35-show (Provided with the Touchscreen drivers).
-then I tried xinput set of the transformation matrix. Sort of worked, but still cursor was jumping big steps (but at least to almost the right places).
-Resetted the matrix to standard.
-found out via xinput list-props that there where malformed evdev settings. Set them to something more convinient. Than it sort of worked. used xinput-calibration the get better values, wrote them to
/etc/X11/xorg.conf.d/99-calibration.conf. (+ an axis inversion for x).
After the next reboot, it took me to the TouchUI Interface (don't know why). And there it also worked.

1 Like