Which cam is which?

**Camera modelWyze Cam V2 Config to USB - works when only camera. Also, Raspi Pi Cam, always works.

**What is the problem?This could be my own lack of linux knowledge, I followed a process here: https://www.makersmashup.com/post/outside-the-box-multiple-webcam-setup-with-octoprint And was able to get both cams working, however I can't get WEBCAMD & WEBCAM2D to run on startup. Also, I want my USB cam to be the main cam, and pi cam to be secondary.

**What did you already try to solve it?I can manually get them running, usually, but I'm uncertain on how to consistently get them to show up, and in the correct spots, ie: usbcam on dev1 and picam on dev? I am using Octolapse and Multicam plugins.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support) THERE IS NO LOG FILE FOR WEBCAMD OR WEBCAM2D IN THE /VAR/LOGS folder.

Additional information about your setup (OctoPrint version, OctoPi version, ...)
Please copy/paste the following when requesting support on the forums or when opening a new bug report:

I am using OctoPrint Version 1.5.3

browser.user_agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.104 Safari/537.36
connectivity.connection_check :
connectivity.connection_ok : true
connectivity.enabled : true
connectivity.online : true
connectivity.resolution_check : octoprint.org
connectivity.resolution_ok : true
env.hardware.cores : 4
env.hardware.freq : 1400
env.hardware.ram : 917016576
env.os.bits : 32
env.os.id : linux
env.os.platform : linux2
env.plugins.pi_support.model : Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version : 0.17.0
env.plugins.pi_support.throttle_state : 0x0
env.python.pip : 19.3.1
env.python.version : 2.7.16
env.python.virtualenv : true
octoprint.safe_mode : false
octoprint.version : 1.5.3
printer.firmware : Marlin 1.1.9 (Github)

UPDATE: I have successfully enabled both cams, Picam and USB cam on the Raspi 3B and in OctoPrint...My only outstanding issue is having webcam2d load automatically at startup. I have to manually run it each time the pi reboots. Thanks in advance.

1 Like