Why does the bed and hot end warm up separately?

What is the problem? I've noticed that when I start a print in OctoPrint it first warms up the bed and then waits for that to get to temp and then warms up the hot end. Why do they warm up sequentially and not in parallel? seems like a waste of time to wait for the bed to warm before the hot end warms up.Is there any way to change this?

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible) I have an Ender 3 pro, stock firmware, Cura 4.4.0, OctoPrint 1.3.12

This video answers your question.

1 Like

also this plugin is pretty handy

1 Like

Just so you know, there are reasons why the bed normally heats up before the extruder.

Heating up the bed and extruder from cold takes more energy than keeping them hot. Your PSU may not like having to heat up everything from cold at the same time.

The bed normally takes much longer to heat up than the extruder. Say the extruder takes up 1 minute, and the bed 10. If you start heating them both up at the same time, that means that the extruder will be at temperature for 9 minutes before the bed finishes heating. Because nothing is extruding yet, the same material is being kept at high temperature all this time. Depending on the material, this could degrade the material in the nozzle, potentially leading to nozzle clogs. Another scenario is that the heat will creep up through the material to the heat break and the cold end, with the risk of heating up parts of your head that are not supposed to be hot. Finally, material could start oozing out in the 9 minutes that the material is hot and not being extruded, potentially ruining the start of the print.

3 Likes

OMG, Thank you so much for this, it was driving me bonkers.

@fieldOfView Thank you for the explanation and reasoning, It makes complete sense. It would be great if there were a way to time the heating so they both complete at the same time, or close to the same time. I know the delta between the 2 seems small, but when I have to cancel/restart prints it kind of gets annoying. I end up manually preheating both and letting them sit there warm while I make adjustments to settings or model.

Warm is better than hot.

Cura has a "standby temperature" {material_standby_temperature} for the extruders. What you could do is heat bed and extruder to the bed and standby temperature respectively, and then when the bed is done heating heat up the extruder the rest of the way. Best of all worlds.

The GCode start code below works for me. Heats up both at the same time. I have an Ender 5 stock board. You can replace the curly brackets with the actual temperature number you want to use. But if you have the Preheat plugin, what I have there will probably work better for you.


M140 S{{ plugins.preheat.bed|int() }}
M104 S{{ plugins.preheat.tool0|int() }}
M105
M190 S{{ plugins.preheat.bed|int() }}
M109 S{{ plugins.preheat.tool0|int() }}

1 Like

I signed up to ask the same question (plus one other). Great answer. Thank you.

It doesn't seem like it would be that hard to bring the head up to a low temperature, say 140C, while the print bed is heating. Perhaps the print head could begin heating when the bed gets within {x degrees} of it's target temperature, so they arrive at the same time?

I'm going to try the pre-heat plugin. Great idea. Thank you!