WIFI Not connecting on Octopi (latest release)


What is the problem?

I've tried both a Pi3 and Zero to get OctoPi up and running to connect with my FLSun Delta printer. When I run a wlan0 scan, I can clearly see my router, but I am unable to establish a connection and get an IP address for the Pi device. Abandoning the Zero for now and focusing on the 3 so I can connect a camera down the road.

What did you already try to solve it?

I have been through the FAQ and several forum posts multiple times to get the issue resolved. I've tried setting up the wifi through the raspi-config settings as well as the directions provided in the FAQ to edit the octopi-wpa-supplicant.txt file. I have tried the country code before and after the network settings. No luck. I know the device is capable fo connecting to the router as I have reinstalled Raspbian on the device twice and had no issue connecting to the internet. Even edited the router name so there were no spaces in the name. What could I be missing?


One final piece of information... When I run ifconfig wlan0 on the command line, i get the flags=4099<UP,BROADCAST,MULTICAST> . mtu 1500. Not sure if this helps, but wanted to make sure to give as much information as possible.


The absence of RUNNING in that paragraph of ifconfig's out indicates that you're not connected to your wi-fi network.

Reviewing the Get Help area of this website and the previous requests even this week, we see many people who are in the same boat. Try reading some of those (like this one) to see what the resolution was.


Have you had a look at the "Wifi Setup and Troubleshooting" guide?

It's been a while since I've been back through to see if it needs updating, but it can be a good place to start when troubleshooting a WiFi connection.

When you get it figured out, please be sure to mark the thread solved and let us know what ended up fixing it.