Wifi not connecting to Google WiFi Mesh network

#1

What is the problem?
Wifi not connecting to Google WiFi Mesh network

Hi all,
First post ever here :+1:
I have a google WiFi network setup in my house with 4 hubs in total. My pi 3b will not connect to my network. I manually edit the correct file reboot and it won't connect.
So, being pissed off I turned my hotspot on my phone... Edited the same file to my phones information and my pi3b connects to my phone no problem. As a side note.... retropie on a different pi3b does the same thing and it's a Pita. I gave up on it for a little :slight_smile:

I'm not sure how to trouble shoot this. I tried to search and i come up empty or topics about using the PI's to create your own Mesh.

Please help :beers::pray:

#2

Can you share octoprint. log and serial.log?

#3

The Raspberry Pi 3B will only connect to the 2.4GHz side of that, for what it's worth. I'm assuming that this is included/supported/configured in your setup.

Add a keyboard/monitor/mouse to the Raspi and run an ifconfig. Look for a RUNNING flag for wlan0. If you have that then you likely also have an IPv4 IP address bound to it. Hopefully they're not doing something stupid like only supported IPv6 for this.

The Google software will have a web interface for you to see what's going on. You should visit that address, log in as the admin and see what workstations are connected to your network.

Both the Wi-fi zone and password are case-sensitive.

For your Raspi's /boot/octopi-wpa-supplicant.txt file, you should verify that only one country code has been set and that it's correct for your country. You should visit sudo raspi-config and set all of the localisation settings to include Wi-fi Country and Timezone. Verify that the time is correct within the minute after rebooting.