Wifi on OctoPi 0.15 (pi 3)


I use the image and all seem to work fine, I can access the pi via the web page, even have a webcam working, and can print, if I connect the ethernet cable, however the wifi seem to partly working. I followed the howto on https://discourse.octoprint.org/t/getting-your-wifi-connection-working/184

I edited the three lines in octopi-wpa-supplicant.txt

## WPA/WPA2 secured
  psk="12345"   ## my password
country=ZA # South Africa

I double checked the spelling is correct and verified it on the pi with mcedit and did not found any strange characters.

if I run iwlist wlan0 scan , all the available Wifi's are detected an the above ssid is in the list, but if I removed the ethernet no comms at all. With the ethernet cable I can ping google, install 'mc' etc.

I did however made some changes to /etc/dhcpd.conf ti use a static IP address, un-commented three lines

  1. interface eth0
  2. static ipaddress
  3. static routers

I tried to connect with
iwconfig wlan0 essid "HUAWEI-B539-D9D0" and

iwconfig wlan0 display extra info including "HUAWEI-B539-D9D0" , however wlan0 does not have an IP address.

What am I missing ?


SSH into your Pi

Make the correct changes in options 2 and 4 (make sure you answer as many questions in option 4 as you can)


Theoretically, that should be the end of it since you've already done the wpa-supplicant


Thanks, I ssh quit a few times but have no clue what options 2 and 4 is. Do I have to run a command via the console and then select the options?



Rats. I'm sorry

I forgot to tell you to type sudo raspi-config when you are in SSH



I read that wifi setup in raspi-config would counter act with octopi, is that true of false ?



Ok I did it and the connection works now, thanks ..

Kind Regards


Yer welcome. Again, I apologize for leaving out the critical bit in the instructions :oops:

As to counter acting. Not exactly. When you edit raspi-config, it makes changes in wpa-supplicant. but, you still need to do them both

Happy printing !