WiFi setup and troubleshooting

Just added in the part about a fresh wpa supplicant file, following several discussions on discord where I need one to reference so I know what it looks like!

1 Like

I tried and tried and even reinstalled Octopi, but couldn't get it to connect to my new wifi router.
Then it struck me, raspberry pi 3 doesn't support 5GHz wifi, only 2.4GHz. Then it worked.

2 Likes

Hey there,

i have a very bad Network Connection with my Octopi since a few days.
Retrieving speedtest.net configuration...
Testing from Deutsche Telekom AG (84.142.114.182)...
Retrieving speedtest.net server list...
Retrieving information for the selected server...
Hosted by AlphaCron (Apfelstädt) [70.29 km]: 909.662 ms
Testing download speed................................................................................
Download: 1.76 Mbit/s
Testing upload speed......................................................................................................
Upload: 1.71 Mbit/s

But also in my local network the WLAN speed is awful.
Don´t keep me wrong, my PC does not have any Speed issues. :slight_smile:

My Versions
OctoPrint version : 1.5.2
OctoPi version : 0.17.0

I also have turned off Power Management:off

Where could i go further with my analysis?

Could this because of a plugin i installed? But disabled?

Hey there,

figured out my issue
One of the following plugins was the trigger:
Dashboard
Spoolmanager
PrintJobHistory
And another plugin i cant remember :frowning:

These plugins were installed but disabled.
After I uninstalled them, the networktraffic was OK again. ¯_(ツ)_/¯

Jezus Christ. Having to install Octopi for a 4the time now following this guide. And i meen it's good but damn is this program unnecessarily complex and frustrating.
First, you get no characters when typing the password. So you type and type, never knowing the damn thing is in qwerty and you are on a azerty so it never log's in. Then when you finally figure that out and login with the command screen. You change the password. Fine, i change it... Reboots... Password incorrect... I changed it to just 111. i changed nothing else, how the f can it be incorrect?! Try to login to Octopi on the network? Nop, can't seem to find it anywhere. Did all the Wifi guides step for step. Tried finding the IP. Nothing. It used to run great before. But for some reason after a few weeks it did not show up anymore. So i thought. Ok it's the wifi that's busted after (pretty fast but ok). Next up, just a cable straight in to the PC. Praying i would find anything. Again, nop.

How, for the love of god, how can this be so difficult? With a direct cable in, it should be almost impossible not to find it. Just something to let it show up under a fixed name or anything. I'm not a programmer or anything. But like to think i know my way around a PC.

  • Running Windows 10
  • Raspberry Pi 3 model B
  • Wifi settings are good

Please don't curse in here.

That's usual with Linux based OS.

For this site (OctoPrint.org - Download & Setup OctoPrint) is in English, it is to assume that the OS is setup to English too.

If you are lost on your SSH password:

The LAN cable should go to your router.

1 Like

"The LAN cable should go to your router."
I can't the router is 2 rooms over and 1 story down. That is why it used to be connected to the wifi. Had no problems with it for nearly a year. Then suddenly, poof. No more wifi on the Pi. Nothing changed with the wifi, the Raspberry just wont connect anymore.

A LAN cable into the PC is the only way i can acces the Octoprint interface to maker sure it was installed correctly. And print strait from my PC. But the wifi let me download plugins etc. Now i can't do that anymore and there is a huge cable in the way. Name and pass of the wifi are all correct. So no idea why it wont detect it. Also not sure how it can be connected to my PC but not use it's internet with a LAN cable in it.

There are literally thousands of OctoPrint / OctoPi users successfully using a Raspberry Pi's wireless connection. Since only a few have come here asking for help, I believe it is fair to say it isn't difficult.

Instead of configuring and using WiFi, it is possible to connect a Raspberry Pi to a local area network using a wired (Ethernet) connection. OctoPi is configured to use DHCP on the wired connection and no additional configuration is necessary.

There are occasional problems with WiFi connections ranging from it doesn't work at all to intermittent failures. These problems can usually be solved by carefully documenting the problem (i.e. providing exact details) so that others can help provide a solution. "Wifi settings are good" is NOT an example of providing good documentation.

OctoPi is a re-packaging of the Raspberry Pi OS which is a Linux derivative. Some amount of experience / knowledge on using a Linux system in a Windows environment is desirable, but for most first-time OctoPrint users, the setup documentation contains enough detail to get them started and is not "unnecessarily complex".

You are obviously having problems, but you are not communicating with us in a manner that lends itself to helping you fix it.

My suggestion is to disconnect your RPi from your printer, carry it 2 rooms over and 1 story down and plug it in next to your router. Start reading this topic from the beginning especially the section "Other Diagnostic Commands". Open a brand new, Get Help, topic and provide ALL the details requested in the template (and try to keep your emotions out of it). We will then try to help you get things working again and once working close to the router, if it fails to work when moved back to the printer location, we will have a good idea why.

4 Likes

@b-morgan - spot on and exactly why I started the guide in the first place (and I appreciate the updates that others have made along the way). What is in there won't solve (or even diagnose) every problem, but it did cover the bulk of the problems folks were experiencing at the time it was written. I'm glad it still has some utility (I've not reviewed it with more recent versions of OctoPrint/OctoPi, but hopefully things have not changed enough to invalidate what is here.)

At some point, I suppose I should go back and delete the "OctoPi 0.14 or older" stuff. There have been enough new versions since then, that I'm guessing it no longer has any use. Unless folks think there is some point in keeping that here?

Since only a few have come here asking for help, I believe it is fair to say it isn't difficult.
Most ppl with a Pi are already at home in programming. That's not to say, most of the Pi users in general are programmers or have been hobby programming a while. Very little of the Pi users have 0 experience with programming. And the ones that do just ask ppl to do it for them or find a work around instead of fix it.

"Wifi settings are good" is NOT an example of providing good documentation.
With "Wifi settings are good" i ment the ones i entered with the installation guide from Octoprint itself.

#WPA/WPA2 secured
#network={
#  ssid="put SSID here"
#  psk="put password here"
#}

This one. Double checked; all correct to wifi login specs. Same as last time i installed Octoprint to the RPi.

"You are obviously having problems, but you are not communicating with us in a manner that lends itself to helping you fix it."
That is because the info expected is the info some one with programming experience would give. And thus is expected as normal by ppl with that exp. I have no idea where to get the info or what info would be needed. Nor if the info i would provide would be endangering my network. This is not that uncommon. It happens in most branches. Like a car mechanic assuming most ppl know some stuff about a car when talking about it.

For ex. The guide talked about finding your router IP, logging in to it and checking your Rpi's IP that way. Took me 3 days to find out how to get that info XD (providers like to make it very difficult here, protecting everything even in your own user menu). Oc useless now as there is no connection, so ni RPi IP. I have a direct connection to my PC so i can use Octoprint to print from Pc to printer again. But still no wifi.

The RPi just does not see any Wifi networks anymore. And WiFi Signal Strength (on it with my PC thats next to the Pi, very strong/fast), Hidden SSID(nop), Weak/Inadequate Power Supply(still all the same from a year ago), Electrical Interference(same as last answer). As taking a screen down, hooking it all up and looking at the code etc is a job that would take several hours. As i would need to move halve my house around. I will pass on that option. Just not possible really. But thx for the suggestion.

(and try to keep your emotions out of it).
I was not emotional, that why i used the ***, to keep it civil :). That's just how i'm used to talking, srry. I already adjusted the previous post ^^

Please tell me you have removed the comments, and that this paste is not what you have on your Pi.

It should look like this, shown:

The kind of information we are looking for is not difficult, and it doesn't need you to know exactly how to do everything. If we expected this, we wouldn't have such busy forums or discord server. I think what @b-morgan's point is, there was not much information describing the processes or what you ended up with. Doesn't have to be technical, by any means, we understand English :slightly_smiling_face:

My point above is related to this - provide exactly what you have, if you want to take the wifi password out instead then fine, that is perfectly understandable. Now I have to wait to see if this was your mistake, or if it is just a copy paste without checking to see that yours had the correct edits. This is the first place we can start, and then move on from here.

If you read what I wrote, I am referring to the set of OctoPi / OctoPrint users which, I will argue, are not programmers but are 3D printing enthusiasts just like yourself. Some of them (like myself) are also programmers / information technology professionals but we hang out here and try to help because we are also 3D printing enthusiasts.

What I've gathered so far is that what used to work for you doesn't work anymore and you haven't changed anything. If you are interested in our help, then you are our eyes, ears, and hands (unless, of course, you want to hire one of us to make a house call). This well written guide takes you through all the steps necessary to troubleshoot WiFi problems but if there's anything here that's unclear to you, please ask specific questions and we'll try and help.

Hehe, no no, i removed the comments. Was just a copy past of the guide to show what part i was talking about :slight_smile:

## WPA/WPA2 secured
network={
  ssid="JoesWiFi"
  psk="12345"
}

is what i have. Oc with my own SSID name and psk. The wifi just stopped working one day. No changes to any software or hardware connected to the RPi. Just the RPi going "Nop. Not gone find any wifi anymore" Wife is fine, working on it day in day out. other devices connect to it with no problem all around the house, phones, laptops etc.

I believe you should consider a hardware failure of the RPi's WiFi.

I've been pulling my hair out for a few days now.
The Router has assigned a IP to octopi.lan.
From Windows 10 I've tried octopi.lan, octopi.local, octopi.lan.local, the IP, the IP.local.
I've re-flashed octopi several times.
I can SSH into it just using the IP, why can't Windows connect?!
FINALLY! There it is! After logging in SSH, right there in the header, are like 4 different strings you can use to access the pi! There is IP by it's self, octopi.lan, then there are a couple of strings using port addressing. I tried one of those, copy and paste into my Google and, Voilà! The SSH user name is: pi, and the password is: raspberry. And yes the password is not displayed so you have to remember what you typed........

Use Putty to connect via SSH. I use it from W10, Ubuntu 20.10, Raspberry Pi OS. It works great & I've used it over 20 years. For all kinds of linux administration, else for a gui, use vnc.